aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-05-01 15:54:44 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-05-04 10:32:09 +0000
commit1ecd82679913332ed94823aab160b0ad41f2c1df (patch)
treee4c292fa1bd1c55c89792aebcc22a9b3bb09ebe2 /testing
parent5b4253ecc2cbb259c1abc71c4c6a3c6cf25d3606 (diff)
downloadaports-1ecd82679913332ed94823aab160b0ad41f2c1df.tar.bz2
aports-1ecd82679913332ed94823aab160b0ad41f2c1df.tar.xz
testing/nemo-keepalive: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/nemo-keepalive/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/nemo-keepalive/APKBUILD b/testing/nemo-keepalive/APKBUILD
new file mode 100644
index 0000000000..8b8443d475
--- /dev/null
+++ b/testing/nemo-keepalive/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=nemo-keepalive
+pkgver=1.7.3
+pkgrel=0
+pkgdesc="Nemo's Keepalive"
+url="https://git.sailfishos.org/mer-core/nemo-keepalive"
+arch="all"
+license="LGPL-2.1-or-later"
+depends_dev="qt5-qtdeclarative-dev libiphb-dev mce-dev"
+makedepends="$depends_dev qt5-qtbase-dev qtchooser"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://git.sailfishos.org/mer-core/nemo-keepalive/-/archive/$pkgver/nemo-keepalive-$pkgver.tar.gz"
+options="!check" # No suitable tests
+
+build() {
+ qmake-qt5
+ make
+}
+
+package() {
+ INSTALL_ROOT="$pkgdir" make install
+
+ # Remove tests
+ rm -rf "$pkgdir"/opt
+}
+
+sha512sums="158270911f5a2f4f7e097f0c5f457061d699f151cd4a27b0ad096fdbe5c41dc0be550050c1d0508d40badcbcd0de43e3e1044dfbce7e172c19317a5f6cce76f6 nemo-keepalive-1.7.3.tar.gz"