aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-27 23:05:12 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-27 23:05:12 -0300
commit38431a72fae3c1e144ea313db405a36050ab0b44 (patch)
tree327294d3d49f69f5e8bd1124ec25e5b453c80326 /testing
parentae289a2b6a6848783222df3b6f5a8591c87a9809 (diff)
downloadaports-38431a72fae3c1e144ea313db405a36050ab0b44.tar.bz2
aports-38431a72fae3c1e144ea313db405a36050ab0b44.tar.xz
testing/perl-bsd-resource: fix url fix license
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-bsd-resource/APKBUILD19
1 files changed, 6 insertions, 13 deletions
diff --git a/testing/perl-bsd-resource/APKBUILD b/testing/perl-bsd-resource/APKBUILD
index 798e02c0e3..bff6fec7b4 100644
--- a/testing/perl-bsd-resource/APKBUILD
+++ b/testing/perl-bsd-resource/APKBUILD
@@ -4,15 +4,12 @@
pkgname=perl-bsd-resource
_pkgreal=BSD-Resource
pkgver=1.2911
-pkgrel=1
+pkgrel=2
pkgdesc="Perl extension implements the BSD process resource limit functions"
-url="http://search.cpan.org/dist/BSD-Resource/"
+url="https://metacpan.org/release/BSD-Resource"
arch="all"
-license="GPL PerlArtistic"
-cpandepends=""
-cpanmakedepends=""
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/J/JH/JHI/$_pkgreal-$pkgver.tar.gz"
@@ -21,24 +18,20 @@ builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
default_prepare
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}