aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-04-03 18:27:55 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-04-03 18:27:55 +0200
commit398c355bd01918ed6c3d0637b0244ba588abe0a1 (patch)
tree8072ffb548d0755f9354e493bd1d214d5f9a1918 /testing
parente38a17d83df361b7d23564363ccee26fc450c2ca (diff)
downloadaports-398c355bd01918ed6c3d0637b0244ba588abe0a1.tar.bz2
aports-398c355bd01918ed6c3d0637b0244ba588abe0a1.tar.xz
community/tlp: move from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/tlp/APKBUILD52
-rw-r--r--testing/tlp/tlp.initd15
2 files changed, 0 insertions, 67 deletions
diff --git a/testing/tlp/APKBUILD b/testing/tlp/APKBUILD
deleted file mode 100644
index 46a2e6e98d..0000000000
--- a/testing/tlp/APKBUILD
+++ /dev/null
@@ -1,52 +0,0 @@
-# Contributor: Ivan Tham <pickfire@riseup.net>
-# Maintainer: Ivan Tham <pickfire@riseup.net>
-pkgname=tlp
-_pkgname=TLP
-pkgver=1.1
-pkgrel=0
-pkgdesc="Linux Advanced Power Management"
-url="http://linrunner.de/en/tlp/tlp.html"
-arch="noarch"
-license="GPL-2.0+"
-options="!check" # no test suite
-subpackages="$pkgname-doc $pkgname-rdw:rdw $pkgname-bash-completion:bashcomp"
-source="$pkgname-$pkgver.tar.gz::https://github.com/linrunner/$_pkgname/archive/$pkgver.tar.gz
- $pkgname.initd"
-builddir="$srcdir/$_pkgname-$pkgver"
-
-build() {
- cd "$builddir"
- make
-}
-
-package() {
- cd "$builddir"
-
- make DESTDIR="$pkgdir" install-tlp
-
- install -dm755 "$pkgdir"/usr/share/man/man1
- install -m644 man/*.1 "$pkgdir"/usr/share/man/man1
- install -dm755 "$pkgdir"/usr/share/man/man8
- install -m644 man/*.8 "$pkgdir"/usr/share/man/man8
- install -m755 "$srcdir"/tlp.initd "$pkgdir"/etc/init.d/$pkgname
-}
-
-rdw() {
- pkgdesc="Linux Advanced Power Management - Radio Device Wizard"
- depends="tlp"
-
- cd "$builddir"
- make DESTDIR="$subpkgdir" install-rdw
-}
-
-bashcomp() {
- pkgdesc="Bash completions for $pkgname"
- depends=""
- install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
-
- mkdir -p "$subpkgdir"/usr/share
- mv "$pkgdir"/usr/share/bash-completion "$subpkgdir"/usr/share
-}
-
-sha512sums="3400f2b6c249fd2e1bbbc61f23e3450ff90fabb8dd74f2903ce1f0d07e7ce3d1e61b07295736138d4697235dbee9157d3f32a8d296a649c93f73e03e3555af1e tlp-1.1.tar.gz
-e6de216b2540413812711b3304cdc29c8729d527080cfd747ba382db50166dd21c6c27ff467f9f2a967e92007c7a311b00e88262952c34a22f417578c66cf4e7 tlp.initd"
diff --git a/testing/tlp/tlp.initd b/testing/tlp/tlp.initd
deleted file mode 100644
index 05b4c3b975..0000000000
--- a/testing/tlp/tlp.initd
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/sbin/openrc-run
-
-description="Initialize tlp"
-extra_started_commands="force_reload"
-
-depend() {
- need localmount
-}
-
-status() { tlp-stat -s; }
-# TODO: keep the following in one line
-start() { tlp init start; }
-stop() { tlp init stop; }
-restart() { tlp init restart; }
-force_reload() { tlp init force-reload; }