aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2015-11-22 02:31:10 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2015-11-22 02:31:10 +0100
commit3a23ff1cefc7bac1e24a8af539ba69c87481299b (patch)
tree89f0b70ba00ea63009919e5cb2c7fb15a2dbd6d1 /testing
parentadc45bc8887631217860443b9a1b576320fa347b (diff)
downloadaports-3a23ff1cefc7bac1e24a8af539ba69c87481299b.tar.bz2
aports-3a23ff1cefc7bac1e24a8af539ba69c87481299b.tar.xz
testing/rsound: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/rsound/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/rsound/APKBUILD b/testing/rsound/APKBUILD
new file mode 100644
index 0000000000..74193b54b4
--- /dev/null
+++ b/testing/rsound/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor:Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=rsound
+_realname=RSound
+pkgver=1.1
+pkgrel=0
+pkgdesc="A multi-platform, simple PCM audio server and client"
+url="https://github.com/Themaister/RSound"
+arch="all"
+license="GPLv3"
+depends=""
+depends_dev="alsa-lib-dev libsamplerate-dev portaudio-dev libao-dev jack-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-libs $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Themaister/${_realname}/archive/v${pkgver}.tar.gz"
+
+_builddir="$srcdir"/${_realname}-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/lib "$pkgdir"/usr/share/man/man1 \
+ "$pkgdir"/usr/lib/pkgconfig
+ make DESTDIR="$pkgdir" -C "$_builddir" install || return 1
+}
+
+md5sums="d416ecd6d1ca39af78c7626ed1b3833e rsound-1.1.tar.gz"
+sha256sums="dd4e32467360c5b49603da9f48bb4e69e4da4f60863a576a9df797091820faf3 rsound-1.1.tar.gz"
+sha512sums="1f55bd1c9cab03cb844ca9d3d4a60413421f20d2a2432e1eff7a55ef662842aa6bb23913e3dcb490b6186feff4ddc462d499db7c45639688398ec42912bce252 rsound-1.1.tar.gz"