aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2020-02-08 21:01:12 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2020-02-14 21:37:33 +0000
commit3b688d6457197778ccafda14cdd203d1362cca03 (patch)
tree4020fac284055b624cfea06e5b9065337b32f49d /testing
parent26e1e59c6cfb1cfe95d5f5110808006462c611d1 (diff)
downloadaports-3b688d6457197778ccafda14cdd203d1362cca03.tar.bz2
aports-3b688d6457197778ccafda14cdd203d1362cca03.tar.xz
testing/various: enable stackprotector
On x86, the stack protector was disabled by addinsg `-fno-stack-protector` to CFLAGS. This was due to rust not passing `-lssp_nonshared` to the linker, causing build errors while linking. Rust has been patched to fix this issue, so now we can enable stack protection again.
Diffstat (limited to 'testing')
-rw-r--r--testing/bat/APKBUILD10
-rw-r--r--testing/ffsend/APKBUILD8
-rw-r--r--testing/mdbook/APKBUILD6
-rw-r--r--testing/mdcat/APKBUILD9
-rw-r--r--testing/procs/APKBUILD9
-rw-r--r--testing/rav1e/APKBUILD6
-rw-r--r--testing/rdedup/APKBUILD9
-rw-r--r--testing/tau/APKBUILD9
8 files changed, 7 insertions, 59 deletions
diff --git a/testing/bat/APKBUILD b/testing/bat/APKBUILD
index b134a7f1cf..e53ba0467c 100644
--- a/testing/bat/APKBUILD
+++ b/testing/bat/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Chloe Kudryavtsev <toast@toastin.space>
pkgname=bat
pkgver=0.12.1
-pkgrel=1
+pkgrel=2
pkgdesc="A cat(1) clone with wings"
url="https://github.com/sharkdp/bat"
arch="x86_64 x86 armhf armv7 aarch64 ppc64le" # limited by rust/cargo
@@ -16,14 +16,6 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/sharkdp/bat/archive/v$pkgver
export CARGO_HOME="$srcdir"/cargo
build() {
- # libminiz_sys fails to build otherwise
- case "$CARCH" in
- x86)
- export CFLAGS="$CFLAGS -fno-stack-protector"
- ;;
- esac
-
-
cargo build \
--release \
--verbose
diff --git a/testing/ffsend/APKBUILD b/testing/ffsend/APKBUILD
index 581ba4b37a..ec1260c483 100644
--- a/testing/ffsend/APKBUILD
+++ b/testing/ffsend/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=ffsend
pkgver=0.2.58
-pkgrel=0
+pkgrel=1
pkgdesc="A fully featured Firefox Send client"
url="https://gitlab.com/timvisee/ffsend"
arch="x86_64 x86 armhf armv7 aarch64 ppc64le" # limited by cargo
@@ -16,12 +16,6 @@ subpackages="
source="https://gitlab.com/timvisee/ffsend/-/archive/v$pkgver/ffsend-v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
-case "$CARCH" in
- x86)
- export CFLAGS="$CFLAGS -fno-stack-protector"
- ;;
-esac
-
build() {
cargo build --release
}
diff --git a/testing/mdbook/APKBUILD b/testing/mdbook/APKBUILD
index 2af669d587..49e0e10a6d 100644
--- a/testing/mdbook/APKBUILD
+++ b/testing/mdbook/APKBUILD
@@ -12,12 +12,6 @@ builddir="$srcdir/mdBook-$pkgver"
export CARGO_HOME="$srcdir"/cargo
build() {
- case "$CARCH" in
- x86)
- export CFLAGS="$CFLAGS -fno-stack-protector"
- ;;
- esac
-
cargo build --release --verbose
}
diff --git a/testing/mdcat/APKBUILD b/testing/mdcat/APKBUILD
index a7aa41ed84..8c2a14cfa2 100644
--- a/testing/mdcat/APKBUILD
+++ b/testing/mdcat/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=mdcat
pkgver=0.15.0
-pkgrel=0
+pkgrel=1
pkgdesc="Cat for markdown"
url="https://github.com/lunaryorn/mdcat"
arch="all !s390x" # Limited by cargo
@@ -15,13 +15,6 @@ builddir="$srcdir/mdcat-mdcat-$pkgver"
export RUSTONIG_DYNAMIC_LIBONING=1
build() {
- # fails linking to libonig w/ stack protector
- case "$CARCH" in
- x86)
- export CFLAGS="$CFLAGS -fno-stack-protector"
- ;;
- esac
-
cargo build --release --locked
}
diff --git a/testing/procs/APKBUILD b/testing/procs/APKBUILD
index 88445470d7..e403d08b8d 100644
--- a/testing/procs/APKBUILD
+++ b/testing/procs/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Chloe Kudryavtsev <toast@toastin.space>
pkgname=procs
pkgver=0.9.9
-pkgrel=0
+pkgrel=1
pkgdesc="A modern replacement for ps written in Rust"
url="https://github.com/dalance/procs"
arch="x86_64 armv7 armhf !aarch64 x86 ppc64le" # limited by rust/cargo (aarch64 due to MAP_32BIT in nix package)
@@ -12,13 +12,6 @@ options="net"
makedepends="cargo"
source="$pkgname-$pkgver.tar.gz::https://github.com/dalance/procs/archive/v$pkgver.tar.gz"
-# disable stack protector on x86 due linking error in cc package
-case "$CARCH" in
- x86)
- export CFLAGS="$CFLAGS -fno-stack-protector"
- ;;
-esac
-
export CARGO_HOME="$srcdir"/cargo
build() {
diff --git a/testing/rav1e/APKBUILD b/testing/rav1e/APKBUILD
index 04da8149cb..99e6498203 100644
--- a/testing/rav1e/APKBUILD
+++ b/testing/rav1e/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Oleg Titov <oleg.titov@gmail.com>
pkgname=rav1e
pkgver=0.3.0
-pkgrel=0
+pkgrel=1
pkgdesc="The fastest and safest AV1 encoder"
url="https://github.com/xiph/rav1e"
arch="all !s390x" # no cargo for s390x
@@ -12,10 +12,6 @@ makedepends="cargo nasm"
subpackages="$pkgname-doc $pkgname-libs $pkgname-static"
source="$pkgname-$pkgver.tar.gz::https://github.com/xiph/rav1e/archive/v$pkgver.tar.gz"
-case "$CARCH" in
- x86) CFLAGS="$CFLAGS -fno-stack-protector" ;;
-esac
-
prepare() {
RUSTFLAGS="-C opt-level=0" \
cargo install --force --root "$srcdir" cargo-c
diff --git a/testing/rdedup/APKBUILD b/testing/rdedup/APKBUILD
index 58eb807fb1..a48292896b 100644
--- a/testing/rdedup/APKBUILD
+++ b/testing/rdedup/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname="rdedup"
pkgver="3.1.1"
-pkgrel=2
+pkgrel=3
pkgdesc="Data deduplication with compression and public key encryption"
url="https://github.com/dpc/rdedup"
arch="x86_64 armv7 armhf aarch64 x86 ppc64le" # limited by cargo
@@ -11,13 +11,6 @@ makedepends="cargo clang-dev libsodium-dev openssl-dev xz-dev"
source="https://github.com/dpc/${pkgname}/archive/${pkgname}-v${pkgver}.tar.gz"
builddir="$srcdir/${pkgname}-${pkgname}-v${pkgver}"
-# disable stack protector on x86 due linking error in cc package
-case "$CARCH" in
- x86)
- export CFLAGS="$CFLAGS -fno-stack-protector"
- ;;
-esac
-
_cargo_env() {
cd "$builddir"
diff --git a/testing/tau/APKBUILD b/testing/tau/APKBUILD
index 369ff2b88e..029975f8ea 100644
--- a/testing/tau/APKBUILD
+++ b/testing/tau/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=tau
pkgver=0.10.2
-pkgrel=0
+pkgrel=1
pkgdesc="GTK frontend for the Xi text editor, written in Rust"
url="https://gitlab.gnome.org/World/Tau"
arch="all !s390x"
@@ -14,13 +14,6 @@ subpackages="$pkgname-lang"
source="https://gitlab.gnome.org/World/Tau/uploads/d7d7fc22a851466768edeace0f3d6b1b/tau-$pkgver.tar.xz"
build() {
- # Fails to compile libbacktrace-sys otherwise
- case "$CARCH" in
- x86)
- export CFLAGS="$CFLAGS -fno-stack-protector"
- ;;
- esac
-
meson \
--prefix=/usr \
--sysconfdir=/etc \