aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-05-01 16:40:33 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-05-04 10:32:10 +0000
commit3c1c52bc097fa421eba3260554857c7de0ffaf36 (patch)
tree87d3a34ea3b5b6fe989704d73f8e04c09d840d13 /testing
parentcce5f63bf8820a62a56e72102d2af88a9069ed74 (diff)
downloadaports-3c1c52bc097fa421eba3260554857c7de0ffaf36.tar.bz2
aports-3c1c52bc097fa421eba3260554857c7de0ffaf36.tar.xz
testing/libconnman-qt: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/libconnman-qt/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/libconnman-qt/APKBUILD b/testing/libconnman-qt/APKBUILD
new file mode 100644
index 0000000000..24f67ce468
--- /dev/null
+++ b/testing/libconnman-qt/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=libconnman-qt
+pkgver=1.2.32
+pkgrel=0
+pkgdesc="Qt bindings for ConnMan"
+url="https://git.sailfishos.org/mer-core/libconnman-qt"
+arch="all"
+license="Apache-2.0"
+depends="connman"
+depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev"
+makedepends="$depends_dev"
+subpackages="$pkgname-dev"
+source="https://git.sailfishos.org/mer-core/libconnman-qt/-/archive/$pkgver/libconnman-qt-$pkgver.tar.gz"
+
+build() {
+ qmake-qt5
+ make
+}
+
+package() {
+ INSTALL_ROOT="$pkgdir" make install
+}
+
+sha512sums="309041a7510de16e1355dadddd7888f1606f92ef4b847d145c97c5ac1765d664e8ad5cb88c818d037973dc3ff348103246066296db890d0cf3f2ebc7f0ea8015 libconnman-qt-1.2.32.tar.gz"