aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-28 01:24:47 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-29 23:22:03 +0000
commit4ad4d0e81ad2c09dde1ced80c11b3e683eb9a8ae (patch)
treed74b6e12289644eb02eb5af1660b4ecece548233 /testing
parent260ab822e5989cb7fa45827a0455107f31051698 (diff)
downloadaports-4ad4d0e81ad2c09dde1ced80c11b3e683eb9a8ae.tar.bz2
aports-4ad4d0e81ad2c09dde1ced80c11b3e683eb9a8ae.tar.xz
testing/ion-shell: new aport
https://gitlab.redox-os.org/redox-os/ion The Ion Shell
Diffstat (limited to 'testing')
-rw-r--r--testing/ion-shell/APKBUILD28
-rw-r--r--testing/ion-shell/ion-shell.post-install3
l---------testing/ion-shell/ion-shell.post-upgrade1
-rw-r--r--testing/ion-shell/ion-shell.pre-deinstall3
4 files changed, 35 insertions, 0 deletions
diff --git a/testing/ion-shell/APKBUILD b/testing/ion-shell/APKBUILD
new file mode 100644
index 0000000000..1f8185782a
--- /dev/null
+++ b/testing/ion-shell/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=ion-shell
+pkgver=1.0.5_git20200428
+pkgrel=0
+_commit=7373a9ce42457632a1f6b5dc25e7fa5194b01c02
+pkgdesc="The Ion Shell"
+url="https://gitlab.redox-os.org/redox-os/ion"
+arch="all !s390x !mips !mips64"
+license="MIT"
+makedepends="cargo"
+install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
+source="$pkgname-$_commit.tar.gz::https://gitlab.redox-os.org/redox-os/ion/-/archive/$_commit.tar.gz"
+builddir="$srcdir/ion-$_commit"
+
+build() {
+ cargo build --release --locked
+}
+
+check() {
+ cargo test --release --locked
+}
+
+package() {
+ install -Dm0755 target/release/ion -t "$pkgdir"/usr/bin
+}
+
+sha512sums="86e4c232e3a7f871373d064e8f2662324d01e7e424819b7d86cb866e0662847d54132b8a7fbda6dade58dd8e4bd88e65ea1983746724fe3ac6d81ad3ffe66786 ion-shell-7373a9ce42457632a1f6b5dc25e7fa5194b01c02.tar.gz"
diff --git a/testing/ion-shell/ion-shell.post-install b/testing/ion-shell/ion-shell.post-install
new file mode 100644
index 0000000000..a40b915462
--- /dev/null
+++ b/testing/ion-shell/ion-shell.post-install
@@ -0,0 +1,3 @@
+#!/bin/sh
+add-shell '/usr/bin/ion'
+exit 0
diff --git a/testing/ion-shell/ion-shell.post-upgrade b/testing/ion-shell/ion-shell.post-upgrade
new file mode 120000
index 0000000000..90eba30cc4
--- /dev/null
+++ b/testing/ion-shell/ion-shell.post-upgrade
@@ -0,0 +1 @@
+ion-shell.post-install \ No newline at end of file
diff --git a/testing/ion-shell/ion-shell.pre-deinstall b/testing/ion-shell/ion-shell.pre-deinstall
new file mode 100644
index 0000000000..e344456932
--- /dev/null
+++ b/testing/ion-shell/ion-shell.pre-deinstall
@@ -0,0 +1,3 @@
+#!/bin/sh
+remove-shell '/usr/bin/ion'
+exit 0