aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-13 16:10:47 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-13 16:19:34 -0300
commit4b6bd8c66609392f52780d979f74fbc90e022d51 (patch)
treeb9565af4baa1f6b7ec89d772a21f32087798451b /testing
parent140c8b6a59315b2c9c9faa27c8bf00951f1931f4 (diff)
downloadaports-4b6bd8c66609392f52780d979f74fbc90e022d51.tar.bz2
aports-4b6bd8c66609392f52780d979f74fbc90e022d51.tar.xz
testing/py3-hidapi: new aport
https://github.com/trezor/cython-hidapi Cython interface for hidapi
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-hidapi/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-hidapi/APKBUILD b/testing/py3-hidapi/APKBUILD
new file mode 100644
index 0000000000..2e9386d029
--- /dev/null
+++ b/testing/py3-hidapi/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-hidapi
+pkgver=0.9.0
+pkgrel=0
+pkgdesc="Cython interface for hidapi"
+url="https://github.com/trezor/cython-hidapi"
+arch="all"
+license="GPL-3.0-or-later"
+depends="python3"
+makedepends="py3-setuptools cython libusb-dev python3-dev eudev-dev hidapi-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/trezor/cython-hidapi/archive/$pkgver.tar.gz"
+builddir="$srcdir/cython-hidapi-$pkgver"
+
+build() {
+ python3 setup.py build --with-system-hidapi
+}
+
+check() {
+ python3 setup.py test --with-system-hidapi
+}
+
+package() {
+ python3 setup.py install --with-system-hidapi --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="0e019902cd20248c889d07c728619094c1fe4f9b12390047921f5b471f3cdd52f61f4f73767a5aab9dd743bff14cf949a609ede23d29ee2ba23d453916bb43c8 py3-hidapi-0.9.0.tar.gz"