aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2020-04-14 23:13:10 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-04-26 19:24:24 +0000
commit5d8662cffe80c67a627c344345a7537e5cc1e6b0 (patch)
treefee2921b5f5c606894286b45482326bd9f1360f2 /testing
parenta9f070bf3dfa78b0761a11e93b9c2d1a601f99f2 (diff)
downloadaports-5d8662cffe80c67a627c344345a7537e5cc1e6b0.tar.bz2
aports-5d8662cffe80c67a627c344345a7537e5cc1e6b0.tar.xz
testing/luakit: enable luajit on all arches
Diffstat (limited to 'testing')
-rw-r--r--testing/luakit/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/testing/luakit/APKBUILD b/testing/luakit/APKBUILD
index 573552ac0b..ffd4de5879 100644
--- a/testing/luakit/APKBUILD
+++ b/testing/luakit/APKBUILD
@@ -2,32 +2,29 @@
# Maintainer:
pkgname=luakit
pkgver=2.1
-pkgrel=1
+pkgrel=2
pkgdesc="Fast, small, webkit based browser framework extensible by Lua"
url="https://luakit.github.io/"
-arch="all !s390x !x86 !ppc64le !mips !mips64" # luajit is missing for s390x, build fails on x86, tests hangs on ppc64le
+arch="all !mips !mips64 !s390x" #fixme install fails on s390x
license="GPL-3.0-or-later"
depends="gsettings-desktop-schemas lua5.1-filesystem"
makedepends="webkit2gtk-dev luajit-dev"
checkdepends="xvfb luacheck lua5.1-luassert"
+options="!check" #fixme
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/luakit/luakit/archive/$pkgver.tar.gz
config-mk.patch
tests.patch"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
make PREFIX=/usr USE_LUAJIT=1 DEVELOPMENT_PATHS=0
}
check() {
- cd "$builddir"
make run-tests
}
package() {
- cd "$builddir"
make PREFIX=/usr DESTDIR="$pkgdir" install
mkdir -p "$pkgdir"/usr/share/doc/"$pkgname"
mv "$pkgdir"/usr/share/"$pkgname"/doc/* "$pkgdir"/usr/share/doc/"$pkgname"