aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorRobert Sacks <robert@sacks.email>2019-07-05 18:33:22 -0400
committerLeo <thinkabit.ukim@gmail.com>2019-11-29 18:03:20 +0100
commit788049d0ab5ea9156b0781cd9f2e8149cf550630 (patch)
tree5fd7f03f3f7c58c1b46548ceca5460bb2fbe47a3 /testing
parent75832840d9f47621b5d750db637919da9c97745d (diff)
downloadaports-788049d0ab5ea9156b0781cd9f2e8149cf550630.tar.bz2
aports-788049d0ab5ea9156b0781cd9f2e8149cf550630.tar.xz
testing/py3-testrepository: new aport
https://launchpad.net/testrepository A repository of test results
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-testrepository/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/py3-testrepository/APKBUILD b/testing/py3-testrepository/APKBUILD
new file mode 100644
index 0000000000..cc998cc859
--- /dev/null
+++ b/testing/py3-testrepository/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Robert Sacks <robert@sacks.email>
+# Maintainer: Robert Sacks <robert@sacks.email>
+pkgname=py3-testrepository
+_pyname=testrepository
+pkgver=0.0.20
+pkgrel=0
+pkgdesc="A repository of test results"
+url="https://launchpad.net/testrepository"
+arch="noarch"
+license="Apache-2.0 OR BSD-3-Clause"
+options="!check" # Test suite issues
+depends="python3 py3-fixtures py3-subunit py3-testtools"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pyname%${_pyname#?}}/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+ rm -rf "$pkgdir"/usr/lib/python3.8/site-packages/testrepository/tests
+}
+
+sha512sums="df14500e2b27b6f39d9d4c4f42961efd63dfe25186e561eb1678952a8ab9311f17c36b78819fea33e0ac879c47a33d45c31ff58be017609c8a6157905ee712d6 testrepository-0.0.20.tar.gz"