aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2015-10-25 18:05:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-10-27 12:05:49 +0000
commit7c4cdfabc973c91316e2e2b05986a6eaeecb5bf3 (patch)
tree29bbd82be4cc3363cf51849a848427b36354fe6c /testing
parentcc0e37e6d3337c3201e48e30ac2673194a9d662d (diff)
downloadaports-7c4cdfabc973c91316e2e2b05986a6eaeecb5bf3.tar.bz2
aports-7c4cdfabc973c91316e2e2b05986a6eaeecb5bf3.tar.xz
testing/spacefm: update to 1.0.4
Diffstat (limited to 'testing')
-rw-r--r--testing/spacefm/APKBUILD15
-rw-r--r--testing/spacefm/fix-malloc_trim.patch84
2 files changed, 5 insertions, 94 deletions
diff --git a/testing/spacefm/APKBUILD b/testing/spacefm/APKBUILD
index 2d2893cba5..3a9e87ecb4 100644
--- a/testing/spacefm/APKBUILD
+++ b/testing/spacefm/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
pkgname=spacefm
-pkgver=1.0.3
+pkgver=1.0.4
pkgrel=0
pkgdesc='Multi-panel tabbed file manager (GTK2 version)'
arch=all
@@ -11,9 +11,7 @@ license='GPL3'
depends='bash'
makedepends='intltool gettext-dev gtk+2.0-dev gtk+3.0-dev eudev-dev ffmpegthumbnailer-dev linux-headers'
subpackages="$pkgname-lang $pkgname-doc $pkgname-gtk3 $pkgname-gtk3-lang:lang3 $pkgname-gtk3-doc:doc3"
-source="saveas-https://github.com/IgnorantGuru/spacefm/archive/$pkgver.tar.gz/$pkgname-$pkgver.tar.gz
- fix-malloc_trim.patch
- "
+source="saveas-https://github.com/IgnorantGuru/spacefm/archive/$pkgver.tar.gz/$pkgname-$pkgver.tar.gz"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -66,9 +64,6 @@ package() {
make -j1 DESTDIR="$pkgdir" install || return 1
}
-md5sums="000e26dc414443f934e3838610cb6174 spacefm-1.0.3.tar.gz
-0d71d0941ef9d443dd7ccf62eff51a13 fix-malloc_trim.patch"
-sha256sums="a6d2db6517d80d9dac65da45412704e3122c65a59f0f4dbd593cea5c4bfa7b6a spacefm-1.0.3.tar.gz
-e2d0d0768ba3ced33c132eb2830af6cb493cf8fb465830cd16bc6c8964c6670a fix-malloc_trim.patch"
-sha512sums="3b5b0c5fba9eeb2de92147f6653dc7dc792a4201f9a5abd27d2fe62333d31b4731e56ab9658ea7026c030a82cc95fc97269eebe394cfd0c78183c41d5d5d6264 spacefm-1.0.3.tar.gz
-5318e57ac833479d28112fb9ef3af5aa892117d4bdce23df78624f0740c13c4ce85fd0bceb9dabd078d008b07e4605fbb1a4817b0fab5f71baa1a4fbda92c90c fix-malloc_trim.patch"
+md5sums="a51a8fab15483ef05a093841783a53f3 spacefm-1.0.4.tar.gz"
+sha256sums="b08df31894f48c43e38ce3f3d32acf0bec67c38164d20f7765a7e4af9e3af7a2 spacefm-1.0.4.tar.gz"
+sha512sums="bbb3d3048c62b0223799468e24abd8614a75d9118ad9d8493e7118882072fb3401f086239dc05a4a742b39b40520771de5bc9fe6735a2c5853ffb5aa961e6112 spacefm-1.0.4.tar.gz"
diff --git a/testing/spacefm/fix-malloc_trim.patch b/testing/spacefm/fix-malloc_trim.patch
deleted file mode 100644
index 85a3b66930..0000000000
--- a/testing/spacefm/fix-malloc_trim.patch
+++ /dev/null
@@ -1,84 +0,0 @@
-diff -urp spacefm-1.0.3/src/main-window.c spacefm-1.0.3.new/src/main-window.c
---- spacefm-1.0.3/src/main-window.c 2015-08-26 14:24:08.000000000 +0000
-+++ spacefm-1.0.3.new/src/main-window.c 2015-08-28 17:11:43.091757948 +0000
-@@ -1216,7 +1216,9 @@ void main_window_toggle_thumbnails_all_w
- /* Ensuring free space at the end of the heap is freed to the OS,
- * mainly to deal with the possibility thousands of large thumbnails
- * have been freed but the memory not actually released by SpaceFM */
-- malloc_trim(0);
-+ #if defined (__GLIBC__)
-+ malloc_trim(0);
-+ #endif
- }
-
- void focus_panel( GtkMenuItem* item, gpointer mw, int p )
-diff -urp spacefm-1.0.3/src/ptk/ptk-file-browser.c spacefm-1.0.3.new/src/ptk/ptk-file-browser.c
---- spacefm-1.0.3/src/ptk/ptk-file-browser.c 2015-08-26 14:24:08.000000000 +0000
-+++ spacefm-1.0.3.new/src/ptk/ptk-file-browser.c 2015-08-28 17:16:58.495770877 +0000
-@@ -1513,7 +1513,9 @@ void ptk_file_browser_finalize( GObject
- * mainly to deal with the possibility that killing the browser results in
- * thousands of large thumbnails being freed, but the memory not actually
- * released by SpaceFM */
-- malloc_trim(0);
-+ #if defined (__GLIBC__)
-+ malloc_trim(0);
-+ #endif
- }
-
- void ptk_file_browser_get_property ( GObject *obj,
-@@ -2703,11 +2705,13 @@ void on_dir_file_listed( VFSDir* dir,
- ptk_file_browser_update_model( file_browser );
- file_browser->busy = FALSE;
-
-- /* Ensuring free space at the end of the heap is freed to the OS,
-- * mainly to deal with the possibility that changing the directory results in
-- * thousands of large thumbnails being freed, but the memory not actually
-- * released by SpaceFM */
-- malloc_trim(0);
-+ /* Ensuring free space at the end of the heap is freed to the OS,
-+ * mainly to deal with the possibility that changing the directory results in
-+ * thousands of large thumbnails being freed, but the memory not actually
-+ * released by SpaceFM */
-+ #if defined (__GLIBC__)
-+ malloc_trim(0);
-+ #endif
-
- g_signal_emit( file_browser, signals[ AFTER_CHDIR_SIGNAL ], 0 );
- //g_signal_emit( file_browser, signals[ CONTENT_CHANGE_SIGNAL ], 0 );
-@@ -4556,7 +4560,9 @@ void ptk_file_browser_refresh( GtkWidget
- /* Ensuring free space at the end of the heap is freed to the OS,
- * mainly to deal with the possibility thousands of large thumbnails
- * have been freed but the memory not actually released by SpaceFM */
-- malloc_trim(0);
-+ #if defined (__GLIBC__)
-+ malloc_trim(0);
-+ #endif
-
- // begin load dir
- file_browser->busy = TRUE;
-diff -urp spacefm-1.0.3/src/vfs/vfs-dir.c spacefm-1.0.3.new/src/vfs/vfs-dir.c
---- spacefm-1.0.3/src/vfs/vfs-dir.c 2015-08-26 14:24:08.000000000 +0000
-+++ spacefm-1.0.3.new/src/vfs/vfs-dir.c 2015-08-28 17:10:12.543754236 +0000
-@@ -21,7 +21,11 @@
- #include <string.h>
-
- #include <fcntl.h> /* for open() */
-+
-+#if defined (__GLIBC__)
- #include <malloc.h> /* for malloc_trim */
-+#endif
-+
- #include <unistd.h> /* for read */
- #include "vfs-volume.h"
-
-@@ -1193,7 +1197,9 @@ void vfs_dir_unload_thumbnails( VFSDir*
- /* Ensuring free space at the end of the heap is freed to the OS,
- * mainly to deal with the possibility thousands of large thumbnails
- * have been freed but the memory not actually released by SpaceFM */
-- malloc_trim(0);
-+ #if defined (__GLIBC__)
-+ malloc_trim(0);
-+ #endif
- }
-
- //sfm added mime change timer