aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2020-02-22 11:40:56 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2020-02-22 11:40:56 +0100
commit7f804747d9f15527f27480dc5bb0bff17e4e1e42 (patch)
tree3adb91e834ee933680fa0b3d5090101d50edf9a7 /testing
parentad826735f2221a33989d95066bb69b19b77af56d (diff)
downloadaports-7f804747d9f15527f27480dc5bb0bff17e4e1e42.tar.bz2
aports-7f804747d9f15527f27480dc5bb0bff17e4e1e42.tar.xz
testing/grantlee: fix build with recent Qt
Diffstat (limited to 'testing')
-rw-r--r--testing/grantlee/0001-Remove-vestigial-ansi-flag.patch27
-rw-r--r--testing/grantlee/0002-fix-build-with-qt-5.13-gcc-8.2.patch27
-rw-r--r--testing/grantlee/APKBUILD8
3 files changed, 60 insertions, 2 deletions
diff --git a/testing/grantlee/0001-Remove-vestigial-ansi-flag.patch b/testing/grantlee/0001-Remove-vestigial-ansi-flag.patch
new file mode 100644
index 0000000000..7301dc58e1
--- /dev/null
+++ b/testing/grantlee/0001-Remove-vestigial-ansi-flag.patch
@@ -0,0 +1,27 @@
+From c989fcf192d01d26866faf6405a28ba4fdce64c3 Mon Sep 17 00:00:00 2001
+From: Stephen Kelly <steveire@gmail.com>
+Date: Sun, 21 Jul 2019 16:00:41 +0100
+Subject: [PATCH] Remove vestigial -ansi flag
+
+This causes the compiler to not operate in C++11 mode, meaning that
+headers such as <type_traits> issue errors.
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 6d51110..9172213 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -59,7 +59,7 @@ endif()
+
+ if (CMAKE_COMPILER_IS_GNUCXX)
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-long-long -std=iso9899:1990 -Wundef -Wcast-align -Werror-implicit-function-declaration -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -Wmissing-format-attribute -fno-common")
+- set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wnon-virtual-dtor -Wno-long-long -ansi -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -fno-check-new -fno-common ")
++ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wnon-virtual-dtor -Wno-long-long -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -fno-check-new -fno-common ")
+
+ if (CMAKE_BUILD_TYPE MATCHES TestCocoon)
+ # Needed on 64 bit
+--
+2.22.0
+
diff --git a/testing/grantlee/0002-fix-build-with-qt-5.13-gcc-8.2.patch b/testing/grantlee/0002-fix-build-with-qt-5.13-gcc-8.2.patch
new file mode 100644
index 0000000000..c96ddb0d49
--- /dev/null
+++ b/testing/grantlee/0002-fix-build-with-qt-5.13-gcc-8.2.patch
@@ -0,0 +1,27 @@
+From 1b4f22431ae35dfd11f07a5ae88a1b4db3de2a85 Mon Sep 17 00:00:00 2001
+From: Michael Pyne <mpyne@kde.org>
+Date: Tue, 18 Dec 2018 17:47:21 -0500
+Subject: [PATCH] Fix build with Qt 5.13 / GCC 8.2.
+
+At this point Grantlee doesn't build for me because QList is an
+incomplete type. I think the compiler is right to complain, so I fix by
+including the appropriate header.
+
+Fixes issue #47.
+---
+ templates/lib/lexer_p.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/templates/lib/lexer_p.h b/templates/lib/lexer_p.h
+index 275aeea..1ae451a 100644
+--- a/templates/lib/lexer_p.h
++++ b/templates/lib/lexer_p.h
+@@ -24,7 +24,7 @@
+ #include "textprocessingmachine_p.h"
+ #include "token.h"
+
+-template <typename T> class QList;
++#include <QList>
+
+ namespace Grantlee
+ {
diff --git a/testing/grantlee/APKBUILD b/testing/grantlee/APKBUILD
index 789f69a024..8e468dda68 100644
--- a/testing/grantlee/APKBUILD
+++ b/testing/grantlee/APKBUILD
@@ -10,7 +10,9 @@ license="LGPL-2.1-or-later"
depends_dev="qt5-qtbase-dev qt5-qtscript-dev graphviz-dev"
makedepends="$depends_dev cmake doxygen graphviz"
checkdepends="xvfb-run"
-source="http://downloads.grantlee.org/$pkgname-$pkgver.tar.gz"
+source="http://downloads.grantlee.org/$pkgname-$pkgver.tar.gz
+ 0001-Remove-vestigial-ansi-flag.patch
+ 0002-fix-build-with-qt-5.13-gcc-8.2.patch"
subpackages="$pkgname-dev $pkgname-doc"
build() {
@@ -30,4 +32,6 @@ package() {
DESTDIR="$pkgdir" make install
install -Dm644 apidox/* -t "$pkgdir"/usr/share/doc/$pkgname
}
-sha512sums="2b806a0770b9c6d02f207d5b4939ae8cae325de4fa01901320ffef5c8442ef0f1c10dd799966d0bf0d223e6541f93db8568aaf922ea1b334bcb2f85f6373a936 grantlee-5.1.0.tar.gz"
+sha512sums="2b806a0770b9c6d02f207d5b4939ae8cae325de4fa01901320ffef5c8442ef0f1c10dd799966d0bf0d223e6541f93db8568aaf922ea1b334bcb2f85f6373a936 grantlee-5.1.0.tar.gz
+4c196b7a533beb60b9b64760f419442ab7eef154b5650b88dbfa8f7682b16dd2f290eed1717235397abde32cbd601230baadac108042bed361c2ebf3d1fd9514 0001-Remove-vestigial-ansi-flag.patch
+552e1831dd58d9751a56d09bef9b7548e5f7e7e6bc7b71cefd21cee4bce99c0fd4fd31978729e6677041731a73bf01c93ff1b984906bd44c584e9d83f54aac3a 0002-fix-build-with-qt-5.13-gcc-8.2.patch"