aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorAntoine Fontaine <antoine.fontaine@epfl.ch>2019-12-06 16:55:36 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-30 23:38:35 +0100
commit8fbb853c51b7e72dc353adf241d9b73fd2cd8e7f (patch)
treee11785688b6600b2c3ecaddd3d97a0f614056497 /testing
parent320ce2cb638bf088e59852be6c21ad4092c54581 (diff)
downloadaports-8fbb853c51b7e72dc353adf241d9b73fd2cd8e7f.tar.bz2
aports-8fbb853c51b7e72dc353adf241d9b73fd2cd8e7f.tar.xz
testing/py3-wheel: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-wheel/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/py3-wheel/APKBUILD b/testing/py3-wheel/APKBUILD
new file mode 100644
index 0000000000..cf23eaedcb
--- /dev/null
+++ b/testing/py3-wheel/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Antoine Fontaine <antoine.fontaine@epfl.ch>
+# Maintainer: Antoine Fontaine <antoine.fontaine@epfl.ch>
+pkgname="py3-wheel"
+_pyname="wheel"
+pkgver="0.33.6"
+pkgrel=0
+pkgdesc="A built-package format for Python"
+url="https://github.com/pypa/wheel"
+arch="noarch"
+license="MIT"
+subpackages="$pkgname-doc"
+depends="python3"
+makedepends="py3-setuptools"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pyname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+ install -Dm 0644 "$srcdir"/$_pyname-$pkgver/docs/index.rst "$pkgdir/usr/share/doc/py3-wheel"
+}
+sha512sums="887020c543ce7720c37f4d52f3f482365203ccb232d29c780d5593758c60997ac5383ea4724d4dc0b7237e2366f3d98a28773c18d15d6f7e898721cd6ac94cc6 wheel-0.33.6.tar.gz"