aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-01 12:45:31 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-02 04:38:01 +0000
commit92af3188a66adc82334e5bd9ae2f5d4c6f161fa8 (patch)
treeee32b6906e7f2d257a9844ce362d0a5967a03e55 /testing
parentd38b2a2c033ad638e9ac83e694e49a3bb4f7d786 (diff)
downloadaports-92af3188a66adc82334e5bd9ae2f5d4c6f161fa8.tar.bz2
aports-92af3188a66adc82334e5bd9ae2f5d4c6f161fa8.tar.xz
testing/libcotp: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/libcotp/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/libcotp/APKBUILD b/testing/libcotp/APKBUILD
new file mode 100644
index 0000000000..ffee6edfc4
--- /dev/null
+++ b/testing/libcotp/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=libcotp
+pkgver=1.2.2
+pkgrel=0
+pkgdesc="Library for generating TOTP and HOTP"
+options="!check" # Requires unpackaged 'criterion'
+url="https://github.com/paolostivanin/libcotp"
+arch="all"
+license="Apache-2.0"
+makedepends="libbaseencode-dev libgcrypt-dev cmake"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/paolostivanin/libcotp/archive/v${pkgver}.tar.gz"
+
+build() {
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="eb52259ccd273b9176939b2670e31ab5289f2b5a708b5c4206e23d3a368839fee79235b7cec6745db0b33ac41159459c897a4719f539e5850efacfd04d3c9ed1 libcotp-1.2.2.tar.gz"