aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-07-28 13:12:27 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-07-28 13:13:49 +0200
commit9cdc5ce98caae6063e14237a5b54d89d6542bcb8 (patch)
treec187a592d6225a0a81ed4e33bad486c1eb192a1a /testing
parentb167cf490e6a48ad8284547f698959164ba218aa (diff)
downloadaports-9cdc5ce98caae6063e14237a5b54d89d6542bcb8.tar.bz2
aports-9cdc5ce98caae6063e14237a5b54d89d6542bcb8.tar.xz
testing/tarantool: fix location of sysconfdir and remove /etc/default
Diffstat (limited to 'testing')
-rw-r--r--testing/tarantool/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/testing/tarantool/APKBUILD b/testing/tarantool/APKBUILD
index 2f7c4e2058..2c448cdf79 100644
--- a/testing/tarantool/APKBUILD
+++ b/testing/tarantool/APKBUILD
@@ -4,7 +4,7 @@
pkgname=tarantool
pkgver=1.7.4.335
_series=${pkgver%.*}; _series=${_series%.*} # x.y
-pkgrel=1
+pkgrel=2
pkgdesc="Lua application server integrated with a database management system"
url="https://tarantool.org"
arch="all !x86 !ppc64le !s390x" # bundled LuaJIT is not supported on these
@@ -54,6 +54,7 @@ build() {
-DCMAKE_C_FLAGS="$CFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc \
-DCMAKE_SKIP_RPATH=ON \
-DCMAKE_VERBOSE_MAKEFILE=ON \
-DENABLE_BUNDLED_LIBCORO=OFF \
@@ -80,7 +81,10 @@ check() {
package() {
cd "$builddir"
+
make DESTDIR="$pkgdir" install
+ rm -R "$pkgdir"/etc/default
+
install -Dm755 "$srcdir"/tarantool.initd "$pkgdir"/etc/init.d/tarantool
}