aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-03-01 23:49:38 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-03-02 10:15:07 +0100
commit9f3c6cd034506d8980866f91b3b6bb00c5f53c88 (patch)
treee06f075940fa3460e03f4afea24c59df83c4bd4a /testing
parent757450744f4742816a59711af4e43cd38262e486 (diff)
downloadaports-9f3c6cd034506d8980866f91b3b6bb00c5f53c88.tar.bz2
aports-9f3c6cd034506d8980866f91b3b6bb00c5f53c88.tar.xz
community/rustup: move from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/rustup/APKBUILD66
-rw-r--r--testing/rustup/dont-copy-rustup-bin.patch14
2 files changed, 0 insertions, 80 deletions
diff --git a/testing/rustup/APKBUILD b/testing/rustup/APKBUILD
deleted file mode 100644
index 68cb2e4ffa..0000000000
--- a/testing/rustup/APKBUILD
+++ /dev/null
@@ -1,66 +0,0 @@
-# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
-pkgname=rustup
-pkgver=1.21.1
-pkgrel=0
-pkgdesc="The Rust toolchain installer"
-url="rustup.rs"
-arch="x86_64" # limited by cargo
-license="Apache-2.0"
-makedepends="cargo perl openssl-dev zlib-dev curl-dev"
-options="!check" # Doesn't recognise x86_64-unknown-linux-musl yet
-subpackages="
- $pkgname-bash-completion:bashcomp:noarch
- $pkgname-fish-completion:fishcomp:noarch
- $pkgname-zsh-completion:zshcomp:noarch"
-source="
- $pkgname-$pkgver.tar.gz::https://github.com/rust-lang/rustup.rs/archive/$pkgver.tar.gz
- dont-copy-rustup-bin.patch"
-
-# It doesn't like our custom triplet
-export RUSTUP_OVERRIDE_BUILD_TRIPLE="x86_64-unknown-linux-musl"
-
-build() {
- cargo build --release --features no-self-update --bin rustup-init
-}
-
-check() {
- cargo test --release
-}
-
-package() {
- install -d "$pkgdir"/usr/bin
- install -m755 target/release/rustup-init "$pkgdir"/usr/bin/
-
- ln -s target/release/rustup-init rustup
- ./rustup completions zsh > rustup.zsh
- ./rustup completions bash > rustup.bash
- ./rustup completions fish > rustup.fish
-}
-
-bashcomp() {
- pkgdesc="$pkgdesc - bash completion"
- install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
-
- install -Dm644 "$builddir"/rustup.bash \
- "$subpkgdir"/usr/share/bash-completion/completions/$pkgname
-}
-
-fishcomp() {
- pkgdesc="$pkgdesc - fish shell completion"
- install_if="$pkgname=$pkgver-r$pkgrel fish"
-
- install -Dm644 "$builddir"/rustup.fish \
- "$subpkgdir"/usr/share/fish/completions/$pkgname.fish
-}
-
-zshcomp() {
- pkgdesc="$pkgdesc -zsh completion"
- depends=""
- install_if="$pkgname=$pkgver-r$pkgrel zsh"
-
- install -Dm644 "$builddir"/rustup.zsh \
- "$subpkgdir"/usr/share/zsh/site-functions/_$pkgname
-}
-sha512sums="c4bac7d7259631cef5f337cec18bffe087e1bed883cd763841e4236f2e51c11b32b5d29b2e60cf3364418e7b9dd53fc2365a9c3c2e203dd19893981718a345ba rustup-1.21.1.tar.gz
-ca28b41a638fe5b1e8b0dcb549bdbed04bada7f41759d14a374dbc6f0823df57c08b65aa4fbce05ced3deafcb96ee3ae38b187ca29e1a9183ee5e91f8577400c dont-copy-rustup-bin.patch"
diff --git a/testing/rustup/dont-copy-rustup-bin.patch b/testing/rustup/dont-copy-rustup-bin.patch
deleted file mode 100644
index bcc6f5ce36..0000000000
--- a/testing/rustup/dont-copy-rustup-bin.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Upstream: No, not upstreamable like this
-Reason: We want the rustup binary in $CARGO_HOME/bin to be of the
-same version as the one we distribute in this rustup package.
---- a/src/cli/self_update.rs.1 2018-12-13 21:56:55.211778812 +0100
-+++ b/src/cli/self_update.rs 2018-12-13 21:56:42.763779768 +0100
-@@ -619,8 +619,7 @@
- if rustup_path.exists() {
- utils::remove_file("rustup-bin", &rustup_path)?;
- }
-- utils::copy_file(&this_exe_path, &rustup_path)?;
-- utils::make_executable(&rustup_path)?;
-+ utils::symlink_file(&this_exe_path, &rustup_path)?;
- install_proxies()
- }