aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-05-01 15:56:36 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-05-04 10:32:09 +0000
commitb4f248e822fabfe075d591a30725f823a0d6a45c (patch)
tree7580db8c3436edd3f063bd5e308c51304a70fc92 /testing
parent133698cfe24319991b9ce8f5c571bcc5d8ec7b37 (diff)
downloadaports-b4f248e822fabfe075d591a30725f823a0d6a45c.tar.bz2
aports-b4f248e822fabfe075d591a30725f823a0d6a45c.tar.xz
testing/libresourceqt: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/libresourceqt/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/libresourceqt/APKBUILD b/testing/libresourceqt/APKBUILD
new file mode 100644
index 0000000000..3972f6d4ab
--- /dev/null
+++ b/testing/libresourceqt/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=libresourceqt
+pkgver=1.30.4
+pkgrel=0
+pkgdesc="Nemo's libresourceqt"
+url="https://git.sailfishos.org/mer-core/libresourceqt"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="qt5-qtbase-dev libresource-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://git.sailfishos.org/mer-core/libresourceqt/-/archive/$pkgver/libresourceqt-$pkgver.tar.gz"
+options="!check" # No suitable tests
+
+build() {
+ qmake-qt5
+ make
+}
+
+package() {
+ INSTALL_ROOT="$pkgdir" make install
+
+ # Remove tests
+ rm -rf "$pkgdir"/opt
+}
+
+sha512sums="76b9606a6555f580ef618936fa1b25e16f176c3b988cc02d0a2591a5ec629ba5ea806378007d445615331836a7347101cdaa661528ea7327afdedcf5e62b6550 libresourceqt-1.30.4.tar.gz"