aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2020-02-25 15:04:33 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2020-02-25 15:04:33 +0000
commitc28c2716fdc6c6ad6f348f7e51cbcefcddf2ce81 (patch)
tree68d170d889dd1a94957f4c7d09d1c2ceb2e7d14c /testing
parent640f11220ebae73880250f3a827466b120fa3f9d (diff)
downloadaports-c28c2716fdc6c6ad6f348f7e51cbcefcddf2ce81.tar.bz2
aports-c28c2716fdc6c6ad6f348f7e51cbcefcddf2ce81.tar.xz
community/lab: move to community
Diffstat (limited to 'testing')
-rw-r--r--testing/lab/APKBUILD64
1 files changed, 0 insertions, 64 deletions
diff --git a/testing/lab/APKBUILD b/testing/lab/APKBUILD
deleted file mode 100644
index d3ba94d6e1..0000000000
--- a/testing/lab/APKBUILD
+++ /dev/null
@@ -1,64 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
-# Maintainer:
-pkgname=lab
-pkgver=0.17.2
-pkgrel=0
-pkgdesc="A Git Wrapper for GitLab"
-url="https://zaquestion.github.io/lab/"
-arch="all"
-license="CC0-1.0"
-depends="git"
-makedepends="go"
-checkdepends="bash"
-subpackages="
- $pkgname-bash-completion:bashcomp:noarch
- $pkgname-zsh-completion:zshcomp:noarch
- "
-source="lab-$pkgver.tar.gz::https://github.com/zaquestion/lab/archive/v$pkgver.tar.gz"
-builddir="$srcdir/src/github.com/zaquestion/$pkgname"
-options="net !check" # Tests require configured GitLab account with SSH keys
-
-export GOPATH="$srcdir"
-export CGO_ENABLED=0
-
-prepare() {
- mkdir -p ${builddir%/*}
- mv "$srcdir"/$pkgname-$pkgver "$builddir"/
- default_prepare
-}
-
-build() {
- GO111MODULE=on go build -ldflags "-X main.version=$pkgver" -o bin/$pkgname
- ./bin/lab completion bash > lab.bash
- ./bin/lab completion zsh > _lab.zsh
-}
-
-package() {
- install -Dm755 "$builddir"/bin/$pkgname \
- "$pkgdir"/usr/bin/$pkgname
-}
-
-cleanup_srcdir() {
- go clean -modcache
- default_cleanup_srcdir
-}
-
-bashcomp() {
- depends=""
- pkgdesc="Bash completions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
-
- install -Dm644 "$builddir"/lab.bash \
- "$subpkgdir"/usr/share/bash-completion/completions/$pkgname
-}
-
-zshcomp() {
- depends=""
- pkgdesc="Zsh completions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel zsh"
-
- install -Dm644 "$builddir"/_lab.zsh \
- "$subpkgdir"/usr/share/zsh/site-functions/_$pkgname
-}
-
-sha512sums="a35dc286b3eca61f2bed8bdea485181a428d50e6584f209a74d92267956e104cb8d37844cb43d5c2422845630db2fea6d37cb99884a705bdfeba88b29ecb195e lab-0.17.2.tar.gz"