aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2018-09-17 12:14:54 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2018-09-19 10:21:22 +0000
commitc3ee28f943e47b845a5b9fefb83a97ed7a517d9c (patch)
treed9d030e42edf8960d945d5679c7e8de456ac79a3 /testing
parentecd2579ef716260e389bde6457e3297d026957d5 (diff)
downloadaports-c3ee28f943e47b845a5b9fefb83a97ed7a517d9c.tar.bz2
aports-c3ee28f943e47b845a5b9fefb83a97ed7a517d9c.tar.xz
community/flatpak-builder: move from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/flatpak-builder/APKBUILD48
-rw-r--r--testing/flatpak-builder/musl-fixes.patch17
2 files changed, 0 insertions, 65 deletions
diff --git a/testing/flatpak-builder/APKBUILD b/testing/flatpak-builder/APKBUILD
deleted file mode 100644
index 4b645b56b6..0000000000
--- a/testing/flatpak-builder/APKBUILD
+++ /dev/null
@@ -1,48 +0,0 @@
-# Contributor: André Klitzing <aklitzing@gmail.com>
-# Maintainer: André Klitzing <aklitzing@gmail.com>
-pkgname=flatpak-builder
-pkgver=1.0.0
-pkgrel=0
-pkgdesc="Tool to build flatpaks from source"
-url="http://flatpak.org"
-arch="all !aarch64"
-license="LGPL-2.1"
-makedepends="flatpak-dev glib-dev libsoup-dev json-glib-dev
- elfutils-dev libdwarf-dev libcap-dev curl-dev"
-subpackages="$pkgname-doc"
-source="https://github.com/flatpak/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz
- musl-fixes.patch"
-builddir="$srcdir/$pkgname-$pkgver"
-
-build() {
- cd "$builddir"
-
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --sbindir=/usr/bin \
- --libexecdir=/usr/lib/$pkgname \
- --disable-static \
- --disable-documentation \
- --with-dwarf-header=/usr/include/libdwarf
-
- make
-}
-
-check() {
- cd "$builddir"
- #make -k check
- ./flatpak-builder --version
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
- install -D -m644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
-}
-
-sha512sums="d586e7e5eb82a84b0e80cd9a08d5a928bbd1eef3e8d1792f0922fb81d9d7df7179c474c133cec6b2e02e4fac21dac820e19f1f4d5b75e332b24b2d96b83f4e70 flatpak-builder-1.0.0.tar.xz
-9287ed146bf71665aa436a2c2110cc5edc829a7b4a3e3190947580850fe9ecfd2bb6adb015c692af022d425fb5259390fcdcbd402e8b0d12ee5d2c1a1071ed4f musl-fixes.patch"
diff --git a/testing/flatpak-builder/musl-fixes.patch b/testing/flatpak-builder/musl-fixes.patch
deleted file mode 100644
index 406a06d834..0000000000
--- a/testing/flatpak-builder/musl-fixes.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- a/config.h.in
-+++ b/config.h.in
-@@ -140,3 +140,14 @@
-
- /* Define to 1 if you need to in order for `stat' and other things to work. */
- #undef _POSIX_SOURCE
-+
-+/* taken from glibc unistd.h and fixes musl */
-+#ifndef TEMP_FAILURE_RETRY
-+#define TEMP_FAILURE_RETRY(expression) \
-+ (__extension__ \
-+ ({ long int __result; \
-+ do __result = (long int) (expression); \
-+ while (__result == -1L && errno == EINTR); \
-+ __result; }))
-+#endif
-+