aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-05-01 16:39:08 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-05-04 10:32:10 +0000
commitcce5f63bf8820a62a56e72102d2af88a9069ed74 (patch)
tree8af2ea27a847294347f4f0b96ca7e6129c76b42a /testing
parent042074ff1251e838c755cdfe61d60fc6c420b949 (diff)
downloadaports-cce5f63bf8820a62a56e72102d2af88a9069ed74.tar.bz2
aports-cce5f63bf8820a62a56e72102d2af88a9069ed74.tar.xz
testing/libsailfishkeyprovider: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/libsailfishkeyprovider/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/libsailfishkeyprovider/APKBUILD b/testing/libsailfishkeyprovider/APKBUILD
new file mode 100644
index 0000000000..7b97711cef
--- /dev/null
+++ b/testing/libsailfishkeyprovider/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=libsailfishkeyprovider
+pkgver=1.0.4
+pkgrel=0
+pkgdesc="Provides a class which can provide decoded keys to client applications"
+url="https://git.sailfishos.org/mer-core/libsailfishkeyprovider"
+arch="all"
+license="LGPL-2.1-only"
+depends_dev="qt5-qtbase-dev"
+makedepends="$depends_dev"
+subpackages="$pkgname-dev"
+source="https://git.sailfishos.org/mer-core/libsailfishkeyprovider/-/archive/$pkgver/libsailfishkeyprovider-$pkgver.tar.gz"
+
+build() {
+ qmake-qt5
+ make
+}
+
+package() {
+ INSTALL_ROOT="$pkgdir" make install
+
+ # Remove installed tests
+ rm -r "$pkgdir"/opt
+}
+
+sha512sums="b08368f0f2e9b6a66b7cc9ac6910f80c5ee4cc120701dc663784b486c93b6d0c5dc74455779c78030fd7ff711a2d349042ac00f29a31f336dacd3441d939b742 libsailfishkeyprovider-1.0.4.tar.gz"