aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorAndy Li <andy@onthewings.net>2019-11-28 17:00:18 +0000
committerLeo <thinkabit.ukim@gmail.com>2019-11-28 19:35:51 +0100
commite199f56afa3229578da6b9ab0ac92eb09c0d5d6b (patch)
tree28b5829dcbb9bd9e88c8d17cc9f00c1864429b59 /testing
parent8b235a30725b38ba2a21bd95cc4660a6de1a203f (diff)
downloadaports-e199f56afa3229578da6b9ab0ac92eb09c0d5d6b.tar.bz2
aports-e199f56afa3229578da6b9ab0ac92eb09c0d5d6b.tar.xz
testing/ocaml-obuild: new aport
https://github.com/ocaml-obuild/obuild Simple package build system for ocaml
Diffstat (limited to 'testing')
-rw-r--r--testing/ocaml-obuild/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/ocaml-obuild/APKBUILD b/testing/ocaml-obuild/APKBUILD
new file mode 100644
index 0000000000..50f375e92d
--- /dev/null
+++ b/testing/ocaml-obuild/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Andy Li <andy@onthewings.net>
+# Maintainer: Andy Li <andy@onthewings.net>
+pkgname=ocaml-obuild
+_pkgname=obuild
+pkgver=0.1.10
+pkgrel=0
+pkgdesc="Simple package build system for ocaml"
+url="https://github.com/ocaml-obuild/obuild"
+arch="all !x86 !armhf !armv7 !s390x" # limited by ocaml aport
+license="BSD-2-Clause"
+depends="ocaml-runtime"
+makedepends="ocaml ocaml-findlib opam"
+options="!check" # no tests provided
+source="$pkgname-$pkgver.tar.gz::$url/archive/obuild-v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-obuild-v$pkgver"
+
+build() {
+ ./bootstrap
+}
+
+package() {
+ opam-installer -i \
+ --prefix="$pkgdir/usr" \
+ --libdir="$pkgdir/usr/lib/ocaml" \
+ $_pkgname.install
+
+ rm -rf "$builddir/dist"
+}
+
+sha512sums="23667213ec7de6610fd5b3c7e0c5f98c081d0244619ed0c833ad13647b9a40561f21e862574488454993eab84a8467f4b2caa3288293451bb54f08b92d280175 ocaml-obuild-0.1.10.tar.gz"