aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-20 12:39:38 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-20 14:50:55 -0300
commiteabd8dff4c1e318b655a60cd471469d9bd132040 (patch)
tree140fd346e63bfa76766b7f07dc0a4796248e2268 /testing
parent231afb09ae42682b1f0cfa5c28608e53e888fb64 (diff)
downloadaports-eabd8dff4c1e318b655a60cd471469d9bd132040.tar.bz2
aports-eabd8dff4c1e318b655a60cd471469d9bd132040.tar.xz
testing/py3-flake8-snippets: switch to py3
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-flake8-snippets/APKBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/testing/py3-flake8-snippets/APKBUILD b/testing/py3-flake8-snippets/APKBUILD
index 140d671004..8441ccc7b2 100644
--- a/testing/py3-flake8-snippets/APKBUILD
+++ b/testing/py3-flake8-snippets/APKBUILD
@@ -1,26 +1,27 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-flake8-snippets
+pkgname=py3-flake8-snippets
_pkgname=flake8-snippets
pkgver=0.1
-pkgrel=4
+pkgrel=5
pkgdesc="Extension for flake8 which lint for code snippets"
url="https://github.com/bitmazk/flake8-snippets"
arch="noarch"
license="MIT"
depends="flake8"
-makedepends="python3-dev"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-flake8-snippets" # Backwards compatibility
+provides="py-flake8-snippets=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python3 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
md5sums="c1724b6d6442f8c91f92bad33741d687 flake8-snippets-0.1.tar.gz"