aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-03-23 08:54:23 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-03-23 08:54:25 +0000
commit0081041c958f7d28f64f5cafcc10f47daf31fd44 (patch)
tree79cc93981d2c9abb8f889cb886107d881f222bc4 /testing
parent005258257af597a67890667df77c6eedf34b1a1b (diff)
downloadaports-0081041c958f7d28f64f5cafcc10f47daf31fd44.tar.bz2
aports-0081041c958f7d28f64f5cafcc10f47daf31fd44.tar.xz
testing/cpptest: new aport
CppTest is a portable and powerful, yet simple, unit testing framework for handling automated tests in C++.
Diffstat (limited to 'testing')
-rw-r--r--testing/cpptest/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/cpptest/APKBUILD b/testing/cpptest/APKBUILD
new file mode 100644
index 0000000000..cfbd709857
--- /dev/null
+++ b/testing/cpptest/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Roberto Oliveira <robertoguimaraes8@gmail.com>
+# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
+pkgname=cpptest
+pkgver=1.1.2
+pkgrel=0
+pkgdesc="Portable and powerful unit testing framework for handling automated tests in C++"
+url="http://cpptest.sourceforge.net/"
+arch="all"
+license="LGPL"
+subpackages="$pkgname-dev"
+source="https://sourceforge.net/projects/cpptest/files/cpptest/cpptest-1.1.2/cpptest-1.1.2.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ update_config_guess
+}
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
+}
+
+sha512sums="da1030c69a5886e752b9ae08b65c501334c7d2d4abd2174190209ce11ed351239a615b9f7c5019ee601289523b2c21a1205d2042e59aea6c2882d77d636fc57a cpptest-1.1.2.tar.gz"