aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-06-20 08:10:08 +0200
committerTimo Teräs <timo.teras@iki.fi>2017-06-20 07:26:51 +0000
commit22e105232b44327e75de33b8750d1329086ba801 (patch)
treeafd588e2847fabd1eb69a748da90be4defef0cf1 /testing
parent1846c6cc9698db9e7f998c540470a96369228d3e (diff)
downloadaports-22e105232b44327e75de33b8750d1329086ba801.tar.bz2
aports-22e105232b44327e75de33b8750d1329086ba801.tar.xz
testing/toybox: upgrade to 0.9.4
Modernize abuild
Diffstat (limited to 'testing')
-rw-r--r--testing/toybox/APKBUILD24
1 files changed, 11 insertions, 13 deletions
diff --git a/testing/toybox/APKBUILD b/testing/toybox/APKBUILD
index f606b0f9bb..e34d9ac973 100644
--- a/testing/toybox/APKBUILD
+++ b/testing/toybox/APKBUILD
@@ -1,8 +1,7 @@
# Maintainer: André Klitzing <aklitzing@gmail.com>
# Contributor: André Klitzing <aklitzing@gmail.com>
-
pkgname=toybox
-pkgver=0.7.3
+pkgver=0.7.4
pkgrel=0
pkgdesc="A BSD-licensed alternative to busybox"
arch="all"
@@ -12,28 +11,27 @@ depends="attr"
makedepends="bash linux-headers"
subpackages="$pkgname-doc"
source="${pkgname}-${pkgver}.tar.gz::https://landley.net/${pkgname}/downloads/${pkgname}-${pkgver}.tar.gz"
-
builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "${builddir}"
- make defconfig || return 1
- make || return 1
+ cd "$builddir"
+ make defconfig
+ make
}
check() {
- cd "${builddir}"
- make test || return 1
+ cd "$builddir"
+ make test
}
package() {
- cd "${builddir}"
+ cd "$builddir"
#chmod 755 toybox
- #make PREFIX="$pkgdir" install || return 1
+ #make PREFIX="$pkgdir" install
- install -Dm755 toybox "$pkgdir"/bin/toybox || return 1
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/COPYING || return 1
+ install -Dm755 toybox "$pkgdir"/bin/toybox
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-sha512sums="8f6fcf156fbfedb706f3048b535369e235c47a40087405e54f0b0de877691c41b700b2ddd8c0d5abd6e09367f313c2eef1bc659331b2391738f6f0eefc9115fd toybox-0.7.3.tar.gz"
+sha512sums="380e8c22f1bcea34ee345b9bcfd9459c7bcde8518d0f5c74227ced2e59b063f619e1b6314c1af4e0371d7300fe916d55510272469a061c4232005b7533b09022 toybox-0.7.4.tar.gz"