aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-03-06 20:28:52 +0200
committerAndy Postnikov <apostnikov@gmail.com>2018-03-22 02:54:45 +0200
commit241b2798ee2c89590b6aa8ceeabb583015618b30 (patch)
tree3f4c0e7d0fd92cf275e7662127566fdf1dfcd685 /testing
parentc028994c1443a5a7cf477efbbc4d16251e444a13 (diff)
downloadaports-241b2798ee2c89590b6aa8ceeabb583015618b30.tar.bz2
aports-241b2798ee2c89590b6aa8ceeabb583015618b30.tar.xz
testing/php7-gmagick: add check, modernize
Diffstat (limited to 'testing')
-rw-r--r--testing/php7-gmagick/APKBUILD34
1 files changed, 16 insertions, 18 deletions
diff --git a/testing/php7-gmagick/APKBUILD b/testing/php7-gmagick/APKBUILD
index 5a2623d346..1f5a29caf8 100644
--- a/testing/php7-gmagick/APKBUILD
+++ b/testing/php7-gmagick/APKBUILD
@@ -4,40 +4,38 @@ pkgname=php7-gmagick
_pkgreal=gmagick
pkgver=2.0.5_rc1
_pkgver=${pkgver/_rc/RC}
-pkgrel=4
+pkgrel=0
pkgdesc="PHP7 bindings to the GraphicsMagick library"
url="http://pecl.php.net/package/gmagick"
arch="all"
license="PHP"
-depends=
+depends=""
makedepends="graphicsmagick-dev autoconf libtool php7-dev"
-install=
-subpackages=
source="http://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
builddir="$srcdir/$_pkgreal-$_pkgver"
-prepare() {
- default_prepare || return 1
-
- cd "$builddir"
- phpize7 || return 1
-}
-
build() {
cd "$builddir"
+ phpize7
./configure \
--prefix=/usr \
- --with-php-config=/usr/bin/php-config7 \
- || return 1
- make || return 1
+ --with-php-config=/usr/bin/php-config7
+ make
+}
+
+check() {
+ cd "$builddir"
+ # Test broken because of fonts collisions ghostscript-fonts and libwmf
+ # https://bugs.alpinelinux.org/issues/8619
+ rm tests/gmagick-006-annotateimage.phpt
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
}
package() {
cd "$builddir"
- make INSTALL_ROOT="$pkgdir" install || return 1
- install -d "$pkgdir"/etc/php7/conf.d || return 1
- echo "extension=$_pkgreal.so" > \
- "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
+ make INSTALL_ROOT="$pkgdir" install
+ install -d "$pkgdir"/etc/php7/conf.d
+ echo "extension=$_pkgreal.so" "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
}
sha512sums="217ad5ba2df7f6092fbb2dc13918f85658793033ba03550657be1ff44dc51ae0533a7ae86c0b14c60e8a0dc8fe9af16daffa01cc50a4096d269ad55d60a3dfb8 gmagick-2.0.5RC1.tgz"