aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-06-21 22:37:23 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2017-06-22 00:52:32 +0200
commit6f5a45b42d7cc18f4eb2b05e163ff6046797c954 (patch)
tree5892c3e9c294f9a466cd5fdcb6ef468d6053fc46 /testing
parent02e78a59eeb97125e76ebccaa8f8c2a1d70866f8 (diff)
downloadaports-6f5a45b42d7cc18f4eb2b05e163ff6046797c954.tar.bz2
aports-6f5a45b42d7cc18f4eb2b05e163ff6046797c954.tar.xz
testing/monero: remove dependency to libunwind
Diffstat (limited to 'testing')
-rw-r--r--testing/monero/APKBUILD8
-rw-r--r--testing/monero/easylogging.patch11
2 files changed, 16 insertions, 3 deletions
diff --git a/testing/monero/APKBUILD b/testing/monero/APKBUILD
index b9bd179a94..86e9d3f405 100644
--- a/testing/monero/APKBUILD
+++ b/testing/monero/APKBUILD
@@ -2,13 +2,14 @@
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=monero
pkgver=0.10.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="Secure, private, untraceable cryptocurrency"
url="https://getmonero.org/"
-arch="all !x86 !ppc64le" #libunwind unavail on excluded arches
+arch="all"
license="BSD"
-makedepends="unbound-dev libressl-dev boost-dev libunwind-dev miniupnpc-dev cmake"
+makedepends="unbound-dev libressl-dev boost-dev miniupnpc-dev cmake"
source="$pkgname-$pkgver.tar.gz::https://github.com/monero-project/$pkgname/archive/v$pkgver.tar.gz
+ easylogging.patch
libunwind.patch
"
builddir="$srcdir/"$pkgname-$pkgver
@@ -27,4 +28,5 @@ package() {
}
sha512sums="6856e6078eee5a9036cf7276490a00121b6670b417fd9d8ba8360746af320813fb26f3021079483a61a4bb0179627cfe687435a4146a4ce3cf4d4ad5d500ea95 monero-0.10.3.1.tar.gz
+9d431f87fae5d1fd0d7bb893164c8124bebf682bd3c14b1c4143091837912e36830aa462b05505637f1583595e6259b2d3bbef4706f8875b7ae24c3d0515b255 easylogging.patch
7dba2020c7cd8e6bcaad778089c4f28132a27c8a18db656c08ab112f81b0faab0eb6aa27f5eafe33f604599db687297627f78cc3ee89f61538007cf8d9c13a42 libunwind.patch"
diff --git a/testing/monero/easylogging.patch b/testing/monero/easylogging.patch
new file mode 100644
index 0000000000..f36d96a1e0
--- /dev/null
+++ b/testing/monero/easylogging.patch
@@ -0,0 +1,11 @@
+--- a/external/easylogging++/easylogging++.h
++++ b/external/easylogging++/easylogging++.h
+@@ -195,7 +195,7 @@
+ # define ELPP_INTERNAL_INFO(lvl, msg)
+ #endif // (defined(ELPP_DEBUG_INFO))
+ #if defined(ELPP_STACKTRACE_ON_CRASH)
+-# if (ELPP_COMPILER_GCC && !ELPP_MINGW)
++# if (__has_include(<execinfo.h>) && ELPP_COMPILER_GCC && !ELPP_MINGW)
+ # define ELPP_STACKTRACE 1
+ # else
+ # define ELPP_STACKTRACE 0