aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorMichael Truog <mjtruog@gmail.com>2017-06-20 13:19:08 -0700
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-06-23 13:54:26 +0000
commit85bf78badec654840346643bfc77454682514779 (patch)
tree57efe7620107a22f941cf18420d45b7541a20087 /testing
parent71abf9be23cdcb6cc1c356eaaa2b6026396fe98a (diff)
downloadaports-85bf78badec654840346643bfc77454682514779.tar.bz2
aports-85bf78badec654840346643bfc77454682514779.tar.xz
testing/cloudi: new aport
http://cloudi.org/ CloudI is an open-source private cloud computing framework for efficient, scalable, and stable soft-realtime event processing.
Diffstat (limited to 'testing')
-rw-r--r--testing/cloudi/0005-Disable-pgsql-mysql-tests-for-aports-travis-build.patch19
-rw-r--r--testing/cloudi/APKBUILD87
-rw-r--r--testing/cloudi/cloudi.initd29
3 files changed, 135 insertions, 0 deletions
diff --git a/testing/cloudi/0005-Disable-pgsql-mysql-tests-for-aports-travis-build.patch b/testing/cloudi/0005-Disable-pgsql-mysql-tests-for-aports-travis-build.patch
new file mode 100644
index 0000000000..56dd7d5e84
--- /dev/null
+++ b/testing/cloudi/0005-Disable-pgsql-mysql-tests-for-aports-travis-build.patch
@@ -0,0 +1,19 @@
+--- src/rebar_src_test.config.in
++++ src/rebar_src_test.config.in
+@@ -8,8 +8,6 @@
+ {sub_dirs,
+ ["lib/cloudi_core",
+ "lib/cloudi_service_api_requests",
+- "lib/cloudi_service_db_mysql",
+- "lib/cloudi_service_db_pgsql",
+ "lib/cloudi_service_filesystem",
+ "lib/cloudi_service_http_client",
+ "lib/cloudi_service_http_cowboy",
+@@ -17,7 +15,6 @@
+ "lib/cloudi_service_http_rest",
+ "lib/cloudi_service_map_reduce",
+ "lib/cloudi_service_monitoring",
+- "lib/cloudi_service_oauth1",
+ "lib/cloudi_service_queue",
+ "lib/cloudi_service_quorum",
+ "lib/cloudi_service_router",
diff --git a/testing/cloudi/APKBUILD b/testing/cloudi/APKBUILD
new file mode 100644
index 0000000000..6cf8886440
--- /dev/null
+++ b/testing/cloudi/APKBUILD
@@ -0,0 +1,87 @@
+# Contributor: Michael Truog <mjtruog@gmail.com>
+# Maintainer: Michael Truog <mjtruog@gmail.com>
+pkgname=cloudi
+pkgver=1.7.1
+pkgrel=0
+pkgdesc="Cloud computing framework for efficient, scalable, and stable soft-realtime event processing."
+url="http://cloudi.org/"
+license="MIT"
+arch="all"
+depends="g++"
+makedepends="autoconf
+ automake
+ binutils-dev
+ boost-dev
+ boost-system
+ boost-thread
+ erlang
+ erlang-asn1
+ erlang-common-test
+ erlang-crypto
+ erlang-dev
+ erlang-erl-interface
+ erlang-eunit
+ erlang-inets
+ erlang-jinterface
+ erlang-public-key
+ erlang-reltool
+ erlang-sasl
+ erlang-snmp
+ erlang-ssl
+ erlang-syntax-tools
+ erlang-tools
+ erlang-xmerl
+ gmp-dev
+ libexecinfo-dev
+ libtool
+ nodejs
+ openjdk8
+ perl
+ php7
+ python2
+ python2-dev
+ ruby
+ "
+install=""
+subpackages=""
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ 0005-Disable-pgsql-mysql-tests-for-aports-travis-build.patch
+ $pkgname.initd"
+builddir="$srcdir/$pkgname-$pkgver/src"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ ./autogen.sh
+}
+
+build() {
+ cd "$builddir"
+ export PATH="/usr/lib/jvm/java-1.8-openjdk/bin:$PATH"
+ LIBS="-lexecinfo" ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host="$CHOST" \
+ --build="$CBUILD" \
+ --with-cxx-backtrace
+ make -j1
+}
+
+check() {
+ cd "$builddir"
+ make -j1 ct
+}
+
+package() {
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install
+ install -m755 -D "$srcdir"/$pkgname.initd \
+ "$pkgdir"/etc/init.d/$pkgname
+}
+
+sha512sums="6a9260b3d1e81f54e5d765804d43ee04d976239b6eb9d9785ba3762f1822a998a57f58fecab79b10b26b682b169f660bf3d99742debaefd010e171ecc309db35 cloudi-1.7.1.tar.gz
+7134271bb9a183c16aed2de8d3e0909654fa7b2c805abf1b496842f10dc4baf8d49236dd448bc8ba4408013beb350fea69b669751c6f4860e955acbdae63f29a 0005-Disable-pgsql-mysql-tests-for-aports-travis-build.patch
+3eebc8c38a16522df91ea86ae8dae21137e752db6f1dd1d6531319dcd051e9977dc649ccb27d582ca0e82140426f931168721d187cafc2646559932eef475887 cloudi.initd"
diff --git a/testing/cloudi/cloudi.initd b/testing/cloudi/cloudi.initd
new file mode 100644
index 0000000000..e38f9acb2d
--- /dev/null
+++ b/testing/cloudi/cloudi.initd
@@ -0,0 +1,29 @@
+#!/sbin/openrc-run
+
+name=cloudi
+command="/usr/bin/$name"
+command_args=""
+command_background="false"
+
+description="CloudI is an open-source private cloud computing framework for efficient, scalable, and stable soft-realtime event processing."
+
+extra_started_commands="attach"
+description_attach="Attach to the running CloudI Erlang shell"
+
+depend() {
+ need localmount
+ need net
+ after firewall
+}
+start() {
+ $command start
+}
+stop() {
+ $command stop
+}
+restart() {
+ $command restart
+}
+attach() {
+ $command attach
+}