aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2016-06-14 08:55:40 +0200
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2016-06-14 08:55:40 +0200
commitcbe49cfd95ce4f76816678f85ef77a37998bbfa7 (patch)
treea6ce737e9ed8bc36a6e6c4c4f0b1cd7b1cfd22a2 /testing
parentef7649497e06f4dfc4db78f52d53bae50c01b7e4 (diff)
downloadaports-cbe49cfd95ce4f76816678f85ef77a37998bbfa7.tar.bz2
aports-cbe49cfd95ce4f76816678f85ef77a37998bbfa7.tar.xz
testing/lttng-ust: use default prepare and builddir
Diffstat (limited to 'testing')
-rw-r--r--testing/lttng-ust/APKBUILD16
1 files changed, 3 insertions, 13 deletions
diff --git a/testing/lttng-ust/APKBUILD b/testing/lttng-ust/APKBUILD
index 9205f0aa9f..a697ba3afb 100644
--- a/testing/lttng-ust/APKBUILD
+++ b/testing/lttng-ust/APKBUILD
@@ -18,20 +18,10 @@ source="https://lttng.org/files/$pkgname/$pkgname-$pkgver.tar.bz2
limits-h.patch
glibc-strerr-r.patch"
-_builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--prefix=/usr \
|| return 1
@@ -40,7 +30,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}