aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorOliver Smith <ollieparanoid@bitmessage.ch>2017-06-14 23:35:30 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-07-13 23:35:11 +0000
commitf243ef7883038a19295f672a7165063b91799606 (patch)
treed4002ffca4d8c278957516e3abceec465298af02 /testing
parent07b81d0b89d33e0c473f9f4842fac3f04153444e (diff)
downloadaports-f243ef7883038a19295f672a7165063b91799606.tar.bz2
aports-f243ef7883038a19295f672a7165063b91799606.tar.xz
testing/weston: change arch to "all"
Disabled testsuite, as discussed here (with some workarounds, but I could not get the full testsuite working): https://github.com/alpinelinux/aports/pull/1689
Diffstat (limited to 'testing')
-rw-r--r--testing/weston/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/testing/weston/APKBUILD b/testing/weston/APKBUILD
index 99d32b234d..a8a60c1821 100644
--- a/testing/weston/APKBUILD
+++ b/testing/weston/APKBUILD
@@ -7,7 +7,7 @@ _libname=lib$pkgname
_libdir=$_libname-${pkgver%%.*}
pkgdesc="The reference Wayland server"
url="http://wayland.freedesktop.org"
-arch="x86_64 armhf"
+arch="all"
license="MIT"
depends=""
makedepends="wayland-protocols libxkbcommon-dev xkeyboard-config
@@ -29,6 +29,7 @@ subpackages="$pkgname-dev $pkgname-doc $subpackages
"
source="http://wayland.freedesktop.org/releases/$pkgname-$pkgver.tar.xz"
builddir="$srcdir/$pkgname-$pkgver"
+options="!check"
build() {
cd "$builddir"
@@ -51,6 +52,8 @@ build() {
make
}
+# Does not run through, see also:
+# https://github.com/alpinelinux/aports/pull/1689
check() {
make -C "$builddir" check
return 0