aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-05-10 00:23:14 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-05-10 10:42:32 +0000
commitf3aea6e42c60493d9127fa5083631ba40ff75754 (patch)
tree53f7af9af722ab68d86ad79a3f79c86a9aa24299 /testing
parent5a083821ee40c6404f13210373e63b1ae95e1f89 (diff)
downloadaports-f3aea6e42c60493d9127fa5083631ba40ff75754.tar.bz2
aports-f3aea6e42c60493d9127fa5083631ba40ff75754.tar.xz
testing/ffsend: remove shell completion function definitions
They are part of abuild now
Diffstat (limited to 'testing')
-rw-r--r--testing/ffsend/APKBUILD32
1 files changed, 6 insertions, 26 deletions
diff --git a/testing/ffsend/APKBUILD b/testing/ffsend/APKBUILD
index 6e0aed7672..75cdc75c6a 100644
--- a/testing/ffsend/APKBUILD
+++ b/testing/ffsend/APKBUILD
@@ -9,9 +9,9 @@ arch="x86_64 x86 armhf armv7 aarch64 ppc64le" # limited by cargo
license="GPL-3.0-only"
makedepends="cargo openssl-dev"
subpackages="
- $pkgname-zsh-completion:zshcomp:noarch
- $pkgname-fish-completion:fishcomp:noarch
- $pkgname-bash-completion:bashcomp:noarch
+ $pkgname-zsh-completion
+ $pkgname-fish-completion
+ $pkgname-bash-completion
"
source="https://gitlab.com/timvisee/ffsend/-/archive/v$pkgver/ffsend-v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
@@ -27,33 +27,13 @@ check() {
package() {
cargo install --path . --root="$pkgdir/usr"
rm "$pkgdir"/usr/.crates.toml
-}
-
-bashcomp() {
- depends=""
- pkgdesc="Bash completions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
install -Dm644 "$builddir"/contrib/completions/ffsend.bash \
- "$subpkgdir"/usr/share/bash-completion/completions/ffsend
-}
-
-zshcomp() {
- depends=""
- pkgdesc="Zsh compltions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel zsh"
-
+ "$pkgdir"/usr/share/bash-completion/completions/ffsend
install -Dm644 "$builddir"/contrib/completions/_ffsend \
- "$subpkgdir"/usr/share/zsh/site-functions/_ffsend
-}
-
-fishcomp() {
- depends=""
- pkgdesc="Fish completions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel fish"
-
+ "$pkgdir"/usr/share/zsh/site-functions/_ffsend
install -Dm644 "$builddir"/contrib/completions/ffsend.fish \
- "$subpkgdir"/usr/share/fish/completions/ffsend.fish
+ "$pkgdir"/usr/share/fish/completions/ffsend.fish
}
sha512sums="77e29b0b3df2b9be930e8da34db0b76ee71abf041e9f9b8afb77d0533e027b7cc478767ce13395ba76f2d8cc7439b5124198a9e0912cbcd23dbc1de253cf6013 ffsend-v0.2.59.tar.gz"