aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-03-28 09:46:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-28 13:11:27 +0000
commitf847dbfd0c2b2914a50d1254bd0d02e74997f867 (patch)
tree135065117fbc924e5990790da00a5f0d9b22bead /testing
parent77ea3268c4302e8b93791b9b7be44640d165598b (diff)
downloadaports-f847dbfd0c2b2914a50d1254bd0d02e74997f867.tar.bz2
aports-f847dbfd0c2b2914a50d1254bd0d02e74997f867.tar.xz
testing/i2pd: use libressl
Diffstat (limited to 'testing')
-rw-r--r--testing/i2pd/APKBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/testing/i2pd/APKBUILD b/testing/i2pd/APKBUILD
index 6b9692a779..34c867d037 100644
--- a/testing/i2pd/APKBUILD
+++ b/testing/i2pd/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer: l-n-s <supervillain@riseup.net>
pkgname=i2pd
pkgver=2.18.0
-pkgrel=1
+pkgrel=2
pkgdesc="I2P Router written in C++"
url="https://github.com/PurpleI2P/i2pd"
arch="all !aarch64" # build fails on aarch64
license="BSD"
pkgusers="i2pd"
-depends="boost-filesystem boost-system boost-program_options boost-date_time boost-thread boost-iostreams openssl musl-utils libstdc++"
-makedepends="boost-dev openssl-dev openssl"
+depends="musl-utils"
+makedepends="boost-dev libressl-dev libressl zlib-dev"
options="!check"
install="$pkgname.pre-install"
source="https://github.com/PurpleI2P/i2pd/archive/$pkgver/$pkgname-$pkgver.tar.gz
@@ -20,8 +20,7 @@ builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
-
- make
+ make
}
package() {