aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-26 14:00:38 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-03-26 14:05:55 +0200
commitfe6fd4025ae142fd754128c56ee16f6345ac16fd (patch)
tree474b09a2bf61a6f7614ed30964afe0b50a2a5909 /testing
parent83f35a93ac584825aa97fa0315238f85b9a88f47 (diff)
downloadaports-fe6fd4025ae142fd754128c56ee16f6345ac16fd.tar.bz2
aports-fe6fd4025ae142fd754128c56ee16f6345ac16fd.tar.xz
testing/crystal: change help msg "install shards" to recommend apk
Diffstat (limited to 'testing')
-rw-r--r--testing/crystal/APKBUILD4
-rw-r--r--testing/crystal/alpine-shards-help.patch13
2 files changed, 16 insertions, 1 deletions
diff --git a/testing/crystal/APKBUILD b/testing/crystal/APKBUILD
index 8130ce2d66..fee508f579 100644
--- a/testing/crystal/APKBUILD
+++ b/testing/crystal/APKBUILD
@@ -27,6 +27,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/crystal-lang/$pkgname/archiv
fix-codegen-specs.patch
disable-specs-using-GB2312-encoding.patch
libressl.patch
+ alpine-shards-help.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -131,4 +132,5 @@ dec4ed7abfd215eec825bed97b1e40bf3aa8bd959a4ec7153ea1bc51d409d892ebec19ddb0372e3a
0252e850b79d622fe69329fac3653128b1cc0108961c928a9efa8fa5df1bce13692b6a520697c45c37791a9e6547d5ec7f0f11905e8299902055ab3dbdfd7556 aarch64-linux-musl.patch
702927a86c2e934511415e97093fb6fe04e2e63dd5a4e2e2b1fcc772c7f02e037f1b05e516943222f282515fc562618a83442e2d53cc899933a2b2e8ad8dd53d fix-codegen-specs.patch
269976fbc990dde075769e651c9fac6e7e0b39681e55cbd067c6d2a790c58a096bdc9981f62ae69b5217623025ba768daa63bc5316bd8ddd18192d88839aedcb disable-specs-using-GB2312-encoding.patch
-b5c9c03ad6b648759262a896da3dfbe530ea2d626a5d18fbade08af14a32f8556cdcaf593504db405ff6e5772d3bf00d9d1a8af82f677436602c5bbcbf69b1c6 libressl.patch"
+b5c9c03ad6b648759262a896da3dfbe530ea2d626a5d18fbade08af14a32f8556cdcaf593504db405ff6e5772d3bf00d9d1a8af82f677436602c5bbcbf69b1c6 libressl.patch
+2aa476a2077679a72b94c220bbca6a157555f4751227cb34da1f67b1f8a9a549e00ccb2a8b939ee516f31a429f25b67dbb048984ec49a0c01f092385651daf32 alpine-shards-help.patch"
diff --git a/testing/crystal/alpine-shards-help.patch b/testing/crystal/alpine-shards-help.patch
new file mode 100644
index 0000000000..7510d0a144
--- /dev/null
+++ b/testing/crystal/alpine-shards-help.patch
@@ -0,0 +1,13 @@
+This is downstream patch only.
+
+--- a/src/compiler/crystal/command/deps.cr
++++ b/src/compiler/crystal/command/deps.cr
+@@ -5,7 +5,7 @@
+ private def deps
+ path_to_shards = `which shards`.chomp
+ if path_to_shards.empty?
+- error "`shards` executable is missing. Please install shards: https://github.com/crystal-lang/shards"
++ error "`shards` executable is missing. Please install shards: apk add shards"
+ end
+
+ status = Process.run(path_to_shards, args: options, output: Process::Redirect::Inherit, error: Process::Redirect::Inherit)