aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/aalib
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/aalib
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/aalib')
-rw-r--r--unmaintained/aalib/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/unmaintained/aalib/APKBUILD b/unmaintained/aalib/APKBUILD
new file mode 100644
index 0000000000..dadc71f7e8
--- /dev/null
+++ b/unmaintained/aalib/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=aalib
+pkgver=1.4.0
+_pkgver=1.4
+pkgrel=1.rc4
+pkgdesc="An portable ascii art GFX library"
+url="http://aa-project.sourceforge.net/aalib/"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/aa-project/$pkgname-"$_pkgver"rc4.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="d5aa8e9eae07b7441298b5c30490f6a6 aalib-1.4rc4.tar.gz"
+sha256sums="0b214b98850f559e0a9ef7282de2ff336b094e1aacedefff3ffa50f07711db58 aalib-1.4rc4.tar.gz"
+sha512sums="247813d6b232d83c3347f038ea246ce10b70679e2ff2f3c647c3a462aeb0febc4e3b96bba37c71940b55da1ff8872fbc66598b0ac091590c979b6e163792a35d aalib-1.4rc4.tar.gz"