aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/arc-theme
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/arc-theme
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/arc-theme')
-rw-r--r--unmaintained/arc-theme/APKBUILD68
1 files changed, 68 insertions, 0 deletions
diff --git a/unmaintained/arc-theme/APKBUILD b/unmaintained/arc-theme/APKBUILD
new file mode 100644
index 0000000000..f397c7ec1d
--- /dev/null
+++ b/unmaintained/arc-theme/APKBUILD
@@ -0,0 +1,68 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=arc-theme
+_project="horst3180/Arc-theme"
+_sha=5955dfd4603983c7dfffa6e903bf3220df60c03e
+pkgver=20150603
+pkgrel=0
+pkgdesc="A flat theme with transparent elements"
+url="https://github.com/horst3180/Arc-theme"
+arch="noarch"
+license="GPL"
+depends="gtk-murrine-engine"
+depends_dev=""
+makedepends="$depends_dev automake autoconf libtool coreutils"
+install=""
+subpackages="$pkgname-gtk2 $pkgname-gtk3"
+source="$pkgname-$_sha.tar.gz::https://github.com/$_project/archive/$_sha.tar.gz"
+
+_builddir="$srcdir"/${_project#*/}-$_sha
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./autogen.sh || return 1
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-unity \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+gtk2() {
+ pkgdesc="A GTK2 flat theme with transparent elements"
+ mkdir -p "$subpkgdir"/usr/share/themes/Arc
+ mv "$pkgdir"/usr/share/themes/Arc/gtk-2.0 \
+ "$subpkgdir"/usr/share/themes/Arc/ || return 1
+}
+
+gtk3() {
+ pkgdesc="A GTK3 flat theme with transparent elements"
+ mkdir -p "$subpkgdir"/usr/share/themes/Arc
+ mv "$pkgdir"/usr/share/themes/Arc/gtk-3.0 \
+ "$subpkgdir"/usr/share/themes/Arc/ || return 1
+}
+
+md5sums="c0074f11844b2aeabba1f85b5c069c35 arc-theme-5955dfd4603983c7dfffa6e903bf3220df60c03e.tar.gz"
+sha256sums="1b62ee973f0b351a7c6ea76bf11c7758deeb89a0c46ce3bfcff63376b4d8ee66 arc-theme-5955dfd4603983c7dfffa6e903bf3220df60c03e.tar.gz"
+sha512sums="8462c23e53ad951207b8f6a145dfd9cacc0a3963df5d89a1d1a97de9c01f1872febf2ebf91048c966115b66fcc6b4ef842b9e6c1a6c1113878e39e2f492643b2 arc-theme-5955dfd4603983c7dfffa6e903bf3220df60c03e.tar.gz"