aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/array-info
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/array-info
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/array-info')
-rw-r--r--unmaintained/array-info/APKBUILD30
-rw-r--r--unmaintained/array-info/array-info-makefile.patch20
2 files changed, 50 insertions, 0 deletions
diff --git a/unmaintained/array-info/APKBUILD b/unmaintained/array-info/APKBUILD
new file mode 100644
index 0000000000..0ab10ffb6c
--- /dev/null
+++ b/unmaintained/array-info/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=array-info
+pkgver=0.16
+pkgrel=1
+pkgdesc="Retrieve informations and status from RAID controllers"
+url="http://sourceforge.net/projects/array-info/"
+license="GPL2+"
+arch="all"
+depends=""
+makedepends="docbook-xsl gzip"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/${pkgname}_$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ local _xsl=$(echo /usr/share/xml/docbook/xsl-stylesheets-*/manpages/docbook.xsl)
+ make prefix=/usr DOCBOOK2XMAN="xsltproc --nonet $_xsl" \
+ #build_lib build_plugins abuild-info array-info.1.gz \
+}
+
+package() {
+ cd "$_builddir"
+ make prefix=/usr DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="802e9be5e40a5a945956a123fc81f65f array-info_0.16.tar.gz"
+sha256sums="800090f8d6008c60a5018e230071b6f5fc9b81f8a72d38dae3242cf1372eee3a array-info_0.16.tar.gz"
+sha512sums="a671a503cacf12e4cc5b62a3290b0483eb9b8f80923e051867e0afc5f9b06132e6b1c98f6188fe2cfe41ab7c0ead209dd0a3bd1559a7d72bf0a789c445c242ba array-info_0.16.tar.gz"
diff --git a/unmaintained/array-info/array-info-makefile.patch b/unmaintained/array-info/array-info-makefile.patch
new file mode 100644
index 0000000000..db7c18e450
--- /dev/null
+++ b/unmaintained/array-info/array-info-makefile.patch
@@ -0,0 +1,20 @@
+--- Makefile.orig Tue Dec 29 13:46:28 2009
++++ Makefile Tue Dec 29 13:47:38 2009
+@@ -1,5 +1,5 @@
+ DESTDIR =
+-prefix = /usr/local
++prefix = /usr
+ sbindir = $(prefix)/sbin
+ pkglibdir = $(prefix)/lib/array-info
+ mandir = $(prefix)/share/man
+@@ -8,8 +8,8 @@
+
+ INCLUDES = -I./include -I./linuxheaders
+
+-CFLAGS = -g2 -Wall $(INCLUDES) -DARRAY_PLUGIN_PATH=\"$(ARRAY_PLUGIN_PATH)\"
+-LDFLAGS = -L./lib -larray-info -ldl
++CFLAGS += -Wall $(INCLUDES) -DARRAY_PLUGIN_PATH=\"$(ARRAY_PLUGIN_PATH)\"
++LDFLAGS += -L./lib -larray-info -ldl
+ OBJS = array_plugin.o array_utils.o main.o
+
+ ARRAY_PLUGIN_PATH=$(pkglibdir)/plugins