aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/asoundconf
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/asoundconf
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/asoundconf')
-rw-r--r--unmaintained/asoundconf/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/unmaintained/asoundconf/APKBUILD b/unmaintained/asoundconf/APKBUILD
new file mode 100644
index 0000000000..f4a57f76fd
--- /dev/null
+++ b/unmaintained/asoundconf/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=asoundconf
+pkgver=1.2
+pkgrel=0
+pkgdesc="Get and set configuration parameters in ~/.asoundrc.asoundconf"
+url="https://bitbucket.org/stativ/asoundconf"
+arch="noarch"
+license="GPL"
+depends="python py-gtk"
+depends_dev=""
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-${pkgver}.tar.gz::https://bitbucket.org/stativ/$pkgname/get/${pkgver}.tar.gz"
+
+_builddir="$srcdir"/stativ-$pkgname-01a1f5320b0a
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install \
+ --prefix=/usr \
+ --root="$pkgdir" \
+ --optimize=1 || return 1
+}
+
+md5sums="aa12135497217f248e70c6aee286f453 asoundconf-1.2.tar.gz"
+sha256sums="55915ebfb6682b05d6706d70beba4359424fd7567b7b6edc1ad0b6f0686ff22b asoundconf-1.2.tar.gz"
+sha512sums="16b0159564279b44cb3e1ac64b9cd4a5da0abc35a99a70672011ae154fb7f263d38ef08ce81d6b5ad6d813f91f2645e2868e2dedd0dccf575a7313802e5cbb87 asoundconf-1.2.tar.gz"