aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/biblesync/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/biblesync/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/biblesync/APKBUILD')
-rw-r--r--unmaintained/biblesync/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/unmaintained/biblesync/APKBUILD b/unmaintained/biblesync/APKBUILD
new file mode 100644
index 0000000000..9eaa1b7ed6
--- /dev/null
+++ b/unmaintained/biblesync/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Isaac Dunham <ibid.ag@gmail.com>
+# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
+pkgname=biblesync
+pkgver=1.1.2
+pkgrel=1
+pkgdesc="Library for multicasting Bible navigation used by Xiphos"
+url="sf.net/p/gnomesword"
+arch="all"
+license="Public domain"
+depends=""
+depends_dev="util-linux-dev"
+makedepends="cmake $depends_dev gettext-dev linux-headers"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/project/gnomesword/BibleSync/$pkgver/biblesync-$pkgver.tar.gz"
+
+_builddir="$srcdir"/biblesync-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ || return 1
+# --build=$CBUILD
+# --host=$CHOST
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="25bc063de3da2fc087954c746714f735 biblesync-1.1.2.tar.gz"
+sha256sums="886e1ac165b8900254c00a182fa34e3680ef3aa25051418470f15ea09ac02005 biblesync-1.1.2.tar.gz"
+sha512sums="7725c8228e2dff79edaf065ff4d4816a6cf214d1d874817345cc4154142144bce479ca1ae871053886bff4f6610715a27bce81c25c2a636444d5873e93bfdc62 biblesync-1.1.2.tar.gz"