aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/blists
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/blists
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/blists')
-rw-r--r--unmaintained/blists/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/unmaintained/blists/APKBUILD b/unmaintained/blists/APKBUILD
new file mode 100644
index 0000000000..e900f263c6
--- /dev/null
+++ b/unmaintained/blists/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=blists
+pkgver=1.0
+pkgrel=0
+pkgdesc="Web interface to mailing list archives"
+url="http://www.openwall.com/blists/"
+arch="all"
+license="BSD"
+depends=
+makedepends=
+install=
+subpackages=
+source="http://www.openwall.com/blists/blists-$pkgver.tar.gz"
+
+_builddir="$srcdir"/blists-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -D bit "$pkgdir"/usr/bin/bit
+ install -D bindex "$pkgdir"/usr/bin/bindex
+}
+
+md5sums="bd84e3793ec05d3910631e7b55e32630 blists-1.0.tar.gz"