aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/cdpsnarf
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/cdpsnarf
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/cdpsnarf')
-rw-r--r--unmaintained/cdpsnarf/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/unmaintained/cdpsnarf/APKBUILD b/unmaintained/cdpsnarf/APKBUILD
new file mode 100644
index 0000000000..a77a43beba
--- /dev/null
+++ b/unmaintained/cdpsnarf/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=cdpsnarf
+pkgver=0.1.6
+pkgrel=0
+pkgdesc="Network sniffer exclusively written to extract information from CDP packets"
+url="https://github.com/Zapotek/cdpsnarf"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev libpcap-dev"
+install=""
+subpackages=""
+source="$pkgname-$pkgver.zip::https://github.com/Zapotek/$pkgname/archive/v$pkgver.zip"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm755 cdpsnarf "$pkgdir"/usr/bin/cdpsnarf
+ return 0
+}
+
+md5sums="97061a7d01bcb249c7e8b9e49bdf390e cdpsnarf-0.1.6.zip"
+sha256sums="ff53991d43966e311d256e4cc64e31e4f0c90270bb466bdef020920801e18bd9 cdpsnarf-0.1.6.zip"
+sha512sums="3736c4862c62505c48f26dc01c49a83d792427fadb0291cced7fbef6a2fbb3b3278afb7093f5504dc7fcfd5a01b43df12f23833a73270aeae4200e651292f4de cdpsnarf-0.1.6.zip"