aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/cherokee
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/cherokee
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/cherokee')
-rw-r--r--unmaintained/cherokee/APKBUILD53
-rw-r--r--unmaintained/cherokee/cherokee.confd10
-rwxr-xr-xunmaintained/cherokee/cherokee.initd41
3 files changed, 104 insertions, 0 deletions
diff --git a/unmaintained/cherokee/APKBUILD b/unmaintained/cherokee/APKBUILD
new file mode 100644
index 0000000000..771046b9eb
--- /dev/null
+++ b/unmaintained/cherokee/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
+# Contributor: Mika Havela <mika.havela@gmail.com>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=cherokee
+pkgver=1.2.104
+pkgrel=1
+pkgdesc="A very fast, flexible and easy to configure Web Server"
+url="http://www.cherokee-project.com/"
+arch="all"
+license="GPL2"
+depends="pcre rrdtool python"
+depends_dev="openssl-dev gettext-dev ffmpeg-dev geoip-dev"
+makedepends="$depends_dev automake autoconf libtool"
+install=
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="$pkgname-$pkgver.tar.gz::https://github.com/cherokee/webserver/archive/v$pkgver.tar.gz
+ cherokee.initd
+ cherokee.confd
+ "
+
+_builddir="$srcdir"/webserver-$pkgver
+
+build() {
+ cd "$_builddir"
+ ./autogen.sh || return 1
+ ./configure --prefix=/usr \
+ --localstatedir=/var \
+ --sysconfdir=/etc \
+ --with-wwwroot=/var/www \
+ --enable-os-string="Alpine Linux"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+
+ make -j1 DESTDIR="$pkgdir" install || return 1
+
+ install -m755 -D "$srcdir"/$pkgname.initd \
+ "$pkgdir"/etc/init.d/$pkgname || return 1
+ install -m644 -D "$srcdir"/$pkgname.confd \
+ "$pkgdir"/etc/conf.d/$pkgname || return 1
+}
+
+md5sums="2266dd801dc0ccb1b81a38919ad322f4 cherokee-1.2.104.tar.gz
+8cc44726585fa04a2772a0c3faa6a72d cherokee.initd
+bd6a840f72c630ce1eaabe058097584f cherokee.confd"
+sha256sums="5cbd00ff48503eaf90356b2975e311c02977f9166927e57fc23f541a109efd98 cherokee-1.2.104.tar.gz
+ce60a8953fe78bf0c5f688d324a3433382709b1d77d78f1074df73366f9cd70c cherokee.initd
+58db2070b710f2c3b38bc3d3be9703a22434f736cad742320b930b23cd5fa1b8 cherokee.confd"
+sha512sums="1cb68dbfe457a49341eb4e3af4ccf9a55d81d7893b1d0ef2d4f3dbbbe1fde651139a8dac75feec665c7545a9e3d676e3b2745f29fd6ad8eeaeaa5d526004f3dc cherokee-1.2.104.tar.gz
+d0e3a94ba4b6ad839ec227de26ca6d27416abe1640c73803549349edd1e7f8cf37346f8c8b8d948a4bfcaad4c596d5533448e3e084c4dd1260436731a9803c6d cherokee.initd
+3dbe1bef319eb9f59d65194fa71f0b12235245b2f82d995817824be09f312bbad96f72a147fd5ea11b7d503d263e4543b2fca5b49873106b194246c3c75c790f cherokee.confd"
diff --git a/unmaintained/cherokee/cherokee.confd b/unmaintained/cherokee/cherokee.confd
new file mode 100644
index 0000000000..8f719df390
--- /dev/null
+++ b/unmaintained/cherokee/cherokee.confd
@@ -0,0 +1,10 @@
+# Sample conf.d file for alpine linux
+
+#
+# Specify daemon $OPTS here.
+#
+
+OPTS="-d"
+DAEMON_USER="root"
+DAEMON_GROUP="root"
+
diff --git a/unmaintained/cherokee/cherokee.initd b/unmaintained/cherokee/cherokee.initd
new file mode 100755
index 0000000000..5e88e069c3
--- /dev/null
+++ b/unmaintained/cherokee/cherokee.initd
@@ -0,0 +1,41 @@
+#!/sbin/runscript
+
+# Cherokee init.d file for alpine linux.
+
+NAME=cherokee
+DAEMON=/usr/sbin/$NAME
+DAEMON_USER=${DAEMON_USER:-root}
+DAEMON_GROUP=${DAEMON_GROUP:-root}
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ${NAME}"
+ start-stop-daemon --start --quiet \
+ --pidfile /var/run/${NAME}.pid \
+ --user ${DAEMON_USER}:${DAEMON_GROUP} \
+ --exec ${DAEMON} -- ${OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${NAME}"
+ start-stop-daemon --stop --quiet \
+ --exec ${DAEMON} \
+ --pidfile /var/run/${NAME}.pid
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading ${NAME}"
+ if ! service_started "${NAME}" ; then
+ eend 1 "${NAME} is not started"
+ return 1
+ fi
+ start-stop-daemon --stop --oknodo --signal HUP \
+ --exec ${DAEMON} --pidfile /var/run/${NAME}.pid
+ eend $?
+}
+