aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/cv
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/cv
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/cv')
-rw-r--r--unmaintained/cv/APKBUILD40
-rw-r--r--unmaintained/cv/compress-tools.patch11
2 files changed, 51 insertions, 0 deletions
diff --git a/unmaintained/cv/APKBUILD b/unmaintained/cv/APKBUILD
new file mode 100644
index 0000000000..c0fd220910
--- /dev/null
+++ b/unmaintained/cv/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: z3bra <willy at mailoo dot org>
+# Maintainer:
+pkgname=cv
+pkgver=0.5.1
+pkgrel=0
+pkgdesc="Linux tool to show progress for cp, rm, dd, ..."
+url="https://github.com/Xfennec/cv"
+arch="all"
+license="GPL3"
+depends="ncurses-dev"
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=
+source="http://github.com/Xfennec/$pkgname/archive/v$pkgver.tar.gz"
+
+_builddir=$srcdir/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make PREFIX=/usr DESTDIR=$pkgdir install
+}
+
+md5sums="8ac0e1169428b23b46cf509cf30e8e5a v0.5.1.tar.gz"
+sha256sums="d390a26a8db78366be8dfee93819135a106610ba7e3f6d94515c84d5803195d4 v0.5.1.tar.gz"
+sha512sums="af12176cbf2806a411fb9be9709e51f59c34888689f96a46d64ecac0fc93d892673268b2a25253e46ca0dcf711325d67b94ffbe4033dbc3cf733d1a15b712863 v0.5.1.tar.gz"
diff --git a/unmaintained/cv/compress-tools.patch b/unmaintained/cv/compress-tools.patch
new file mode 100644
index 0000000000..696064e60b
--- /dev/null
+++ b/unmaintained/cv/compress-tools.patch
@@ -0,0 +1,11 @@
+--- cv.orig/cv.c
++++ cv/cv.c
+@@ -44,7 +44,7 @@
+ #include "sizes.h"
+ #include "hlist.h"
+
+-char *proc_names[] = {"cp", "mv", "dd", "tar", "gzip", "gunzip", "cat", "grep", "fgrep", "egrep", "cut", "sort", NULL};
++char *proc_names[] = {"cp", "mv", "dd", "tar", "gzip", "gunzip", "cat", "grep", "fgrep", "egrep", "cut", "sort", "cpio", "xz", "bzip2", "bunzip2", NULL};
+ char *proc_specifiq = NULL;
+ WINDOW *mainwin;
+ signed char flag_quiet = 0;