aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/dc3dd
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-10-24 14:05:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-10-24 14:06:11 +0000
commit988327021c2f3d26e45ae67b32616b322cc0c34f (patch)
treef735cd56b1be9789e8236ec1ca97b4b80bced60c /unmaintained/dc3dd
parentbdc363bfa8aced6fd67764e579cca86fdb3518ce (diff)
downloadaports-988327021c2f3d26e45ae67b32616b322cc0c34f.tar.bz2
aports-988327021c2f3d26e45ae67b32616b322cc0c34f.tar.xz
testing/dc3dd: unmaintained
Diffstat (limited to 'unmaintained/dc3dd')
-rw-r--r--unmaintained/dc3dd/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/unmaintained/dc3dd/APKBUILD b/unmaintained/dc3dd/APKBUILD
new file mode 100644
index 0000000000..7a77657534
--- /dev/null
+++ b/unmaintained/dc3dd/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=dc3dd
+pkgver=7.1.614
+pkgrel=0
+pkgdesc="Patched version of GNU dd for use in computer forensics"
+url="http://dc3dd.sourceforge.net/"
+arch="all"
+license="GPL2+ and GPL3+"
+depends=""
+depends_dev=""
+makedepends="libiconv-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/dc3dd/dc3dd-$pkgver.tar.gz"
+_builddir="$srcdir"/dc3dd-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ rm po/*.gmo
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-nls \
+ --disable-rpath \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="b6c4ec16e7f539b17224d7f334f8396e dc3dd-7.1.614.tar.gz"