aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/dhcpdump
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/dhcpdump
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/dhcpdump')
-rw-r--r--unmaintained/dhcpdump/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/unmaintained/dhcpdump/APKBUILD b/unmaintained/dhcpdump/APKBUILD
new file mode 100644
index 0000000000..deb397b676
--- /dev/null
+++ b/unmaintained/dhcpdump/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=dhcpdump
+pkgver=1.8
+pkgrel=0
+pkgdesc="utility to analyze sniffed DHCP packets"
+url="http://www.mavetju.org/unix/general.php"
+arch="all"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends="$depends_dev libpcap-dev perl"
+install=""
+subpackages="$pkgname-doc"
+source="http://www.mavetju.org/download/dhcpdump-$pkgver.tar.gz"
+
+_builddir="$srcdir"/dhcpdump-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -D dhcpdump "$pkgdir"/usr/bin/dhcpdump || return 1
+ install -D dhcpdump.8 "$pkgdir"/usr/share/man/man8/dhcpdump.8 \
+ || return 1
+}
+
+md5sums="099c786997c424f196414f9575f1fb90 dhcpdump-1.8.tar.gz"
+sha256sums="6d5eb9418162fb738bc56e4c1682ce7f7392dd96e568cc996e44c28de7f77190 dhcpdump-1.8.tar.gz"
+sha512sums="52cd63d581a3c530c2f5baa66808d5b0241853651c720bd513b769b8301b4dff9c87243787014aea98a5b3ebed86ec317b58d262bf5031015141a4da50fb76e6 dhcpdump-1.8.tar.gz"