aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/duff
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/duff
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/duff')
-rw-r--r--unmaintained/duff/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/unmaintained/duff/APKBUILD b/unmaintained/duff/APKBUILD
new file mode 100644
index 0000000000..7c46f15708
--- /dev/null
+++ b/unmaintained/duff/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=duff
+pkgver=0.5.2
+pkgrel=0
+pkgdesc="A command-line tool for finding duplicate files"
+url="http://sourceforge.net/projects/duff/"
+arch="all"
+license="ZLIB"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/duff/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ update_config_sub || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="483f9216ebea14b090e0d71dbf7077ff duff-0.5.2.tar.gz"
+sha256sums="15b721f7e0ea43eba3fd6afb41dbd1be63c678952bf3d80350130a0e710c542e duff-0.5.2.tar.gz"
+sha512sums="6fb1ede1e935c25c6bf354fee94ef1d9d454d5b98069ce671600e91767f802ad5c74bc602ad2c9e19a502e29c8c0ffcd0563a779714a16389594ea5678504768 duff-0.5.2.tar.gz"