aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/duhdraw
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/duhdraw
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/duhdraw')
-rw-r--r--unmaintained/duhdraw/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/unmaintained/duhdraw/APKBUILD b/unmaintained/duhdraw/APKBUILD
new file mode 100644
index 0000000000..4c975a0410
--- /dev/null
+++ b/unmaintained/duhdraw/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=duhdraw
+pkgver=2.8.13
+pkgrel=2
+pkgdesc="A program which almost perfectly simulates TheDraw for DOS."
+url="http://www.cs.helsinki.fi/u/penberg/duhdraw/"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev ncurses-dev"
+install=""
+subpackages=""
+source="http://www.cs.helsinki.fi/u/penberg/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p $pkgdir/usr/bin
+ install -m0755 ansi ansitoc duhdraw $pkgdir/usr/bin
+}
+
+md5sums="70211aa3ea927704ffeb9093e4f433b9 duhdraw-2.8.13.tar.gz"
+sha256sums="12a432d2874a6f0579879e3242d832139b7f2a4879b2cfcfb6ced046236b4b2c duhdraw-2.8.13.tar.gz"
+sha512sums="fa9102133dcd100b2cde58d4d92aabfcdf86bb16a8066191e92922d6cea470094ff226e569bf92d34e1f0f6a3e657eaf3326cecf091ed1bc37bd2faace340798 duhdraw-2.8.13.tar.gz"