aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/e_dbus
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/e_dbus
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/e_dbus')
-rw-r--r--unmaintained/e_dbus/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/unmaintained/e_dbus/APKBUILD b/unmaintained/e_dbus/APKBUILD
new file mode 100644
index 0000000000..0cda31c6d9
--- /dev/null
+++ b/unmaintained/e_dbus/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=e_dbus
+pkgver=1.7.9
+pkgrel=0
+pkgdesc="Enlightenment's (Ecore) integration to DBus"
+url="http://trac.enlightenment.org/e/wiki/E_Dbus"
+arch="all"
+license="BSD"
+depends=""
+depends_dev="dbus-dev eina-dev ecore-dev udisks-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://download.enlightenment.org/releases/e_dbus-$pkgver.tar.gz"
+
+_builddir="$srcdir"/e_dbus-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="8f72da14e5664aad8c45eeeca0e3ff5f e_dbus-1.7.9.tar.gz"
+sha256sums="c328c4cf1424629cb67c83689ccc1f95967abcb4c03dffd437e93b799ff151c1 e_dbus-1.7.9.tar.gz"
+sha512sums="4f91d6aea44811a848a80d75cecdd99ca1fdcff8ca2f5a65426e0ef073b41c04a94c80cfa9fcd7d4e73315a3e2a8d1e18068be9520253952cb8350e727be2502 e_dbus-1.7.9.tar.gz"