aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/eeze
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/eeze
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/eeze')
-rw-r--r--unmaintained/eeze/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/unmaintained/eeze/APKBUILD b/unmaintained/eeze/APKBUILD
new file mode 100644
index 0000000000..f019ba184c
--- /dev/null
+++ b/unmaintained/eeze/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=eeze
+pkgver=1.7.8
+pkgrel=0
+pkgdesc="Enlightenment's device library"
+url="http://trac.enlightenment.org/e/wiki/Eeze"
+arch="all"
+license="BSD"
+depends=
+depends_dev="eina-dev ecore-dev udev-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://download.enlightenment.org/releases/eeze-$pkgver.tar.gz"
+
+_builddir="$srcdir"/eeze-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="3ee68667f65860a0bdb7126e555155ff eeze-1.7.8.tar.gz"
+sha256sums="9a4df9d086575c54d0116164d46b2c9e29362cc32398ea606c2365cbdf4157dd eeze-1.7.8.tar.gz"
+sha512sums="17dcf5401e48eeb94f37c21a9184ff45cd510b07ed3d2e1b600b67cb0d48167e3492c0b30b20b19d9ad54d4af05e1b77fae2e4f0ff0e7ddbe889edaa19ee3194 eeze-1.7.8.tar.gz"