aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/equinox-themes/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/equinox-themes/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/equinox-themes/APKBUILD')
-rw-r--r--unmaintained/equinox-themes/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/unmaintained/equinox-themes/APKBUILD b/unmaintained/equinox-themes/APKBUILD
new file mode 100644
index 0000000000..6bc15659bd
--- /dev/null
+++ b/unmaintained/equinox-themes/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=equinox-themes
+pkgver=1.50
+pkgrel=0
+pkgdesc="Equinox GTK Themes"
+url="http://gnome-look.org/content/show.php/Equinox+GTK+Engine?content=121881"
+arch="noarch"
+license="GPL"
+depends="gtk-equinox-engine"
+makedepends=""
+install=""
+subpackages=""
+source="http://gnome-look.org/CONTENT/content-files/140449-equinox-themes-$pkgver.tar.gz"
+
+_builddir="$srcdir"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/share/themes
+ for i in *; do
+ [ -L "$i" ] && continue
+ cp -ra "$i" "$pkgdir"/usr/share/themes/ || return 1
+ done
+}
+
+md5sums="280f0c1f81abbfcdc524bb9c3a8f0ee8 140449-equinox-themes-1.50.tar.gz"