aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/exaile
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/exaile
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/exaile')
-rw-r--r--unmaintained/exaile/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/unmaintained/exaile/APKBUILD b/unmaintained/exaile/APKBUILD
new file mode 100644
index 0000000000..e53066701e
--- /dev/null
+++ b/unmaintained/exaile/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
+# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
+pkgname=exaile
+pkgver=3.4.2
+pkgrel=2
+pkgdesc="A music player with a simple interface and powerful music management capabilities"
+url="http://www.exaile.org/"
+arch="noarch"
+license="GPL2"
+depends="python py-gtk py-dbus py-mutagen py-gst0.10 py-libxml2
+ gst-plugins-base0.10 gst-plugins-good0.10"
+depends_dev=""
+makedepends="$depends_dev gettext"
+install=""
+subpackages="$pkgname-lang"
+source="https://github.com/$pkgname/$pkgname/archive/$pkgver.tar.gz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make PREFIX=/usr DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="ff0081f548bc17435877c2c65b05c9b8 3.4.2.tar.gz"
+sha256sums="0e280c317871e37cbe9db8d54d37a5bee99cf36ebd0f55048e41787d0461e4bf 3.4.2.tar.gz"
+sha512sums="1a13585afc4eaa2b03c3be0bd25394e8c6df824999b676349f6efeabe9286d7c773eaf5938d7a644e9facb9b6184c02cc465fe1ec0d22057ab2cb8a521357312 3.4.2.tar.gz"