aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/fancontroled
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/fancontroled
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/fancontroled')
-rw-r--r--unmaintained/fancontroled/APKBUILD57
-rw-r--r--unmaintained/fancontroled/fancontroled.confd17
-rw-r--r--unmaintained/fancontroled/fancontroled.initd18
-rw-r--r--unmaintained/fancontroled/link.patch11
4 files changed, 103 insertions, 0 deletions
diff --git a/unmaintained/fancontroled/APKBUILD b/unmaintained/fancontroled/APKBUILD
new file mode 100644
index 0000000000..4d04858b43
--- /dev/null
+++ b/unmaintained/fancontroled/APKBUILD
@@ -0,0 +1,57 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=fancontroled
+pkgver=0.1
+pkgrel=2
+pkgdesc="A temperature dependent fan speed control"
+url="http://fancontroled.lukaperkov.net/"
+arch="all"
+license="GPL3"
+depends=""
+makedepends="lm_sensors-dev"
+install=""
+subpackages=""
+source="http://code.lukaperkov.net/fancontroled/fancontroled-$pkgver.tar
+ link.patch
+ fancontroled.confd
+ fancontroled.initd
+ "
+
+_builddir="$srcdir"/fancontroled-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/sbin
+ make install DESTDIR="$pkgdir" || return 1
+ install -Dm644 "$srcdir"/fancontroled.confd \
+ "$pkgdir"/etc/conf.d/fancontroled || return 1
+ install -Dm755 "$srcdir"/fancontroled.initd \
+ "$pkgdir"/etc/init.d/fancontroled || return 1
+}
+
+md5sums="8c3a7efa99e58216ad4633d1e6ed1358 fancontroled-0.1.tar
+099a824ba948f1f01da8d374024357fd link.patch
+3b9e5e1557ad4877e23f88411e8b84f0 fancontroled.confd
+b7e49fce1d8182559b808b1ce3b60e7b fancontroled.initd"
+sha256sums="94b4602dfb913a846e2f40dd87e7085cddb5cd622a46744198a8abde2dcf44b4 fancontroled-0.1.tar
+985490bb1c79cac191b160fe79f0f4d461cdea71d8f16c06b5a21d6613b1949a link.patch
+3b9cc54a16bda45e81874966fa11b866a167f5cd2538da4b275899bc57d739b4 fancontroled.confd
+18e780d5454c2de16641c758e5aeb1e1442eddfe03338230a5e14ba420d468be fancontroled.initd"
+sha512sums="cd59b8db8d44798be31693138dcebe261a684e4a10fc08ffb24488d8d5a9eac6f827e82cf3632509acf91c461308c279fae70f40237d7fe9f48b480ce1cb56bd fancontroled-0.1.tar
+6be24b0445ad2b3e6e7331192e1caba16fa8aa649a6e945ae5fb88d90f38310b4945216ee63facb9c817d1894f90959f056eff65956d7a1bdf5971400f0f7e4a link.patch
+250637ce329d6d28ad801980563eb756b20aa222ca5ad5c8e79f5df51ac154a3ab1577d157e031f1a38409caabbf03e5900992177318393d4b32bbb87599d9ec fancontroled.confd
+4784ad205f719338d23b3e5fe8515c51aa8ceb2a892f7ae05e668a1f2e61f425d195186bd321b13d7ac78a502401ed563d41f226411af09d2e3451b6dbd32ace fancontroled.initd"
diff --git a/unmaintained/fancontroled/fancontroled.confd b/unmaintained/fancontroled/fancontroled.confd
new file mode 100644
index 0000000000..803a9c38d8
--- /dev/null
+++ b/unmaintained/fancontroled/fancontroled.confd
@@ -0,0 +1,17 @@
+# possible options for FANCONTROLED_OPTS:
+# -t --temp-sensor-chip Temperature sensor chip (e.g. lm75)
+# -r --temp-read-field Temperature read fild (e.g. temp1_input)
+# -m --min-temp Min fan speed on this temperature (°C)
+# -M --max-temp Max fan speed on this temperature (°C)
+# -f --fan-sensor-chip Fan sensor chip (e.g. g760a)
+# -c --fan-control-field Fan control field (e.g. pwm1)
+# -p --pwm-fan-min Min fan PWM
+# -P --pwm-fan-max Max fan PWM
+#
+# example:
+# FANCONTROLED_OPTS="-t lm75 -r temp1_input -m 30 -M 50 -f g760a -c pwm1 -p 1 -P 180"
+#
+# see http://fancontroled.lukaperkov.net/ for more info
+
+FANCONTROLED_OPTS=""
+
diff --git a/unmaintained/fancontroled/fancontroled.initd b/unmaintained/fancontroled/fancontroled.initd
new file mode 100644
index 0000000000..1da4422e83
--- /dev/null
+++ b/unmaintained/fancontroled/fancontroled.initd
@@ -0,0 +1,18 @@
+#!/sbin/runscript
+
+command=/usr/sbin/fancontroled
+command_args="${FANCONTROLED_OPTS}"
+pidfile=/var/run/fancontroled.pid
+description="Temperature dependent fan speed control"
+
+depend() {
+ need modules
+}
+
+start_pre() {
+ if [ -z "$FANCONTROLED_OPTS" ]; then
+ eerror "Please set FANCONTROLED_OPTS in /etc/conf.d/$RC_SVCNAME"
+ return 1
+ fi
+}
+
diff --git a/unmaintained/fancontroled/link.patch b/unmaintained/fancontroled/link.patch
new file mode 100644
index 0000000000..328e78062d
--- /dev/null
+++ b/unmaintained/fancontroled/link.patch
@@ -0,0 +1,11 @@
+--- ./Makefile.orig
++++ ./Makefile
+@@ -12,7 +12,7 @@
+ OBJECTS = $(SOURCES:.c=.o)
+
+ $(FANCONTROLED_TARGET): $(OBJECTS) $(HEADERS)
+- $(CC) $(CFLAGS) $(LDFLAGS) $(INC_PATH) $(LIBS) $(OBJECTS) -D $(MACROS) -o $(FANCONTROLED_TARGET)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(INC_PATH) $(OBJECTS) -D $(MACROS) -o $(FANCONTROLED_TARGET) $(LIBS)
+
+ $(OBJECTS): $(SOURCES)
+ $(CC) $(CFLAGS) $(LDFLAGS) $(INC_PATH) $(LIBS) -D $(MACROS) -c $(@:.o=.c)